qualcommax: only build initramfs if CONFIG_TARGET_ROOTFS_INITRAMFS is set
authorFlorian Maurer <f.maurer@outlook.de>
Thu, 26 Oct 2023 06:40:59 +0000 (08:40 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 29 Oct 2023 10:35:46 +0000 (11:35 +0100)
This makes it possible to build the ipq807x netgear-wax218 without initramfs - which is required for downstream projects (gluon)

Signed-off-by: Florian Maurer <f.maurer@outlook.de>
target/linux/qualcommax/image/ipq807x.mk

index f288dae6d85be659aafe7b3cb43cbd0abd1b1674..0be17333b2abee25c24b7904f122b25426284a82 100644 (file)
@@ -128,15 +128,17 @@ TARGET_DEVICES += netgear_rax120v2
 define Device/netgear_wax218
        $(call Device/FitImage)
        $(call Device/UbiFit)
-       ARTIFACTS := web-ui-factory.fit
        DEVICE_VENDOR := Netgear
        DEVICE_MODEL := WAX218
        DEVICE_DTS_CONFIG := config@hk07
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        SOC := ipq8072
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+       ARTIFACTS := web-ui-factory.fit
        ARTIFACT/web-ui-factory.fit := append-image initramfs-uImage.itb | \
                ubinize-kernel | qsdk-ipq-factory-nand
+endif
        DEVICE_PACKAGES := kmod-spi-gpio kmod-spi-bitbang kmod-gpio-nxp-74hc164 \
                ipq-wifi-netgear_wax218
 endef