ath79: use lzma-loader for Senao initramfs images
authorMichael Pratt <mcpratt@pm.me>
Fri, 9 Dec 2022 20:45:04 +0000 (15:45 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 6 Jan 2023 14:34:07 +0000 (15:34 +0100)
Some vendors of Senao boards have put a bootloader
that cannot handle both large gzip or large lzma files.

There is no disadvantage by doing this for all of them.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
target/linux/ath79/image/common-senao.mk

index e0e60dbe277730e33090f595eaf4dab97ea43e30..9034aa28dbc96d85c30841613de6973221014aa8 100644 (file)
@@ -37,6 +37,7 @@ endef
 define Device/senao_loader_okli
   $(Device/loader-okli-uimage)
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x73714f4b
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | uImage none
   LOADER_KERNEL_MAGIC := 0x73714f4b
   IMAGES += factory.bin
   IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \