ath79: image: don't depend on other COMPILE targets
authorAlexander Couzens <lynxis@fe80.eu>
Sat, 3 Dec 2022 14:25:12 +0000 (15:25 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 21 Dec 2022 23:14:30 +0000 (00:14 +0100)
A device COMPILE target should not depend on another COMPILE.
Otherwise race condition may happen.
The loader is very small. Compiling it twice shouldn't
have a huge impact.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
(cherry picked from commit 17c6fb1054e3dde8fa573195acaac42a5edf0942)

target/linux/ath79/image/Makefile

index 712ab941e18a5c336a494fa80c9c5ab87dadde31..8328be7667cf8dd675fc5b4571e1a7a61405c378 100644 (file)
@@ -83,7 +83,7 @@ define Device/loader-okli-uimage
   LOADER_TYPE := bin
   COMPILE := loader-$(1).bin loader-$(1).uImage
   COMPILE/loader-$(1).bin := loader-okli-compile
-  COMPILE/loader-$(1).uImage := append-loader-okli $(1) | pad-to 64k | \
+  COMPILE/loader-$(1).uImage := loader-okli-compile | pad-to 64k | \
        lzma | uImage lzma
 endef