kernel: modules: split smbfs-common from cifs
authorJohn Thomson <git@johnthomson.fastmail.com.au>
Sat, 24 Dec 2022 12:57:34 +0000 (22:57 +1000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 18 May 2023 14:52:05 +0000 (16:52 +0200)
This kernel config symbol is a shared library used for both CIFS and the
in-tree SMB_SERVER.
Split it out into kmod-fs-smbfs-common from kmod-fs-cifs, and depend on
it, so that later in-tree ksmbd may also depend on it.

Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
package/kernel/linux/modules/fs.mk

index 77d8d6c98bc8bb606a67f834fe57624be4610a26..c3c56864b77e7ae271c94b0e2c6848ffe4723b1d 100644 (file)
@@ -83,21 +83,36 @@ endef
 $(eval $(call KernelPackage,fs-btrfs))
 
 
+define KernelPackage/fs-smbfs-common
+  SUBMENU:=$(FS_MENU)
+  TITLE:=SMBFS common dependencies support
+  HIDDEN:=1
+  KCONFIG:=CONFIG_SMBFS_COMMON
+  FILES:= \
+       $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko \
+       $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko
+endef
+
+define KernelPackage/fs-smbfs-common/description
+ Kernel module dependency for CIFS or SMB_SERVER support
+endef
+
+$(eval $(call KernelPackage,fs-smbfs-common))
+
+
 define KernelPackage/fs-cifs
   SUBMENU:=$(FS_MENU)
   TITLE:=CIFS support
   KCONFIG:= \
-       CONFIG_SMBFS_COMMON \
        CONFIG_CIFS \
        CONFIG_CIFS_DFS_UPCALL=n \
        CONFIG_CIFS_UPCALL=n
   FILES:= \
-       $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko \
-       $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko \
        $(LINUX_DIR)/fs/cifs/cifs.ko
   AUTOLOAD:=$(call AutoLoad,30,cifs)
   $(call AddDepends/nls)
   DEPENDS+= \
+    +kmod-fs-smbfs-common \
     +kmod-crypto-md5 \
     +kmod-crypto-sha256 \
     +kmod-crypto-sha512 \