kernel: bump 4.9 to 4.9.223
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 11 May 2020 09:29:01 +0000 (11:29 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 12 May 2020 10:45:57 +0000 (12:45 +0200)
Refreshed all patches.

Fixes:
- CVE-2020-12114

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/403-mtd_fix_cfi_cmdset_0002_status_check.patch
target/linux/ar71xx/patches-4.9/411-mtd-cfi_cmdset_0002-force-word-write.patch
target/linux/ar71xx/patches-4.9/910-unaligned_access_hacks.patch
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/generic/hack-4.9/902-debloat_proc.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index 80aebc99ce40e3ce109965f0a7fa0b734b47517e..6f69898b1b7b59236d204767d0ca88257896c991 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .219
+LINUX_VERSION-4.9 = .223
 LINUX_VERSION-4.14 = .176
 
-LINUX_KERNEL_HASH-4.9.219 = 6b17238cced3e1c2753d6d5b4f662bd347d4651f07c35506b849eb10aea7bc44
+LINUX_KERNEL_HASH-4.9.223 = cf5300e6f5d8c66c2bed8f00d53f9c58103731809862427012e4010f5d782ae5
 LINUX_KERNEL_HASH-4.14.176 = bcae0956baaeb55dab5bad0401873fbc5baaa7fbe957ea6d27a5ab241cec5ca2
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 7f1f6ae0a3b6978f512999fadaa1ba215fc2f283..5fc15589b8018c95038febfb21181211c724813a 100644 (file)
@@ -18,7 +18,7 @@
        xip_enable(map, chip, adr);
   op_done:
        if (mode == FL_OTP_WRITE)
-@@ -2232,7 +2234,6 @@ static int cfi_amdstd_panic_write(struct
+@@ -2236,7 +2238,6 @@ static int cfi_amdstd_panic_write(struct
        return 0;
  }
  
@@ -26,7 +26,7 @@
  /*
   * Handle devices with one erase region, that only implement
   * the chip erase command.
-@@ -2300,7 +2301,7 @@ static int __xipram do_erase_chip(struct
+@@ -2304,7 +2305,7 @@ static int __xipram do_erase_chip(struct
                }
  
                if (chip_good(map, adr, map_word_ff(map)))
@@ -35,7 +35,7 @@
  
                if (time_after(jiffies, timeo)) {
                        printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -2324,6 +2325,7 @@ static int __xipram do_erase_chip(struct
+@@ -2328,6 +2329,7 @@ static int __xipram do_erase_chip(struct
                }
        }
  
@@ -43,7 +43,7 @@
        chip->state = FL_READY;
        xip_enable(map, chip, adr);
        DISABLE_VPP(map);
-@@ -2397,7 +2399,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2401,7 +2403,7 @@ static int __xipram do_erase_oneblock(st
  
                if (chip_good(map, adr, map_word_ff(map))) {
                        xip_enable(map, chip, adr);
@@ -52,7 +52,7 @@
                }
  
                if (time_after(jiffies, timeo)) {
-@@ -2423,6 +2425,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2427,6 +2429,7 @@ static int __xipram do_erase_oneblock(st
                }
        }
  
index 6185651ee8d5463ca3102f9055e5fd413979f73b..7b375ab0fa0aed9c4b117a3ddab4aa2089be5b35 100644 (file)
@@ -43,7 +43,7 @@
  static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
                                    unsigned long adr, const u_char *buf,
                                    int len)
-@@ -1924,7 +1929,6 @@ static int __xipram do_write_buffer(stru
+@@ -1928,7 +1933,6 @@ static int __xipram do_write_buffer(stru
        return ret;
  }
  
@@ -51,7 +51,7 @@
  static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
                                    size_t *retlen, const u_char *buf)
  {
-@@ -1999,6 +2003,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -2003,6 +2007,7 @@ static int cfi_amdstd_write_buffers(stru
  
        return 0;
  }
index 37aaf92e6e3a68322d0471ce6afdc24655aeec6d..2579a12cdd9aad864143888cd2c128b1ed206483 100644 (file)
        for (p = *head; p; p = p->next) {
 --- a/net/ipv4/route.c
 +++ b/net/ipv4/route.c
-@@ -461,7 +461,7 @@ static struct neighbour *ipv4_neigh_look
+@@ -459,7 +459,7 @@ static struct neighbour *ipv4_neigh_look
        else if (skb)
                pkey = &ip_hdr(skb)->daddr;
  
index b125e6a60eb8d27c29427abacb1910dd403a918a..7ae3bba26429f4c17fc9af7bd6a3b4af4554e187 100644 (file)
@@ -696,7 +696,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5095,7 +5095,7 @@ static void port_event(struct usb_hub *h
+@@ -5109,7 +5109,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
@@ -707,7 +707,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
                msleep(100);    /* Cool down */
 --- a/drivers/usb/core/message.c
 +++ b/drivers/usb/core/message.c
-@@ -1924,6 +1924,85 @@ free_interfaces:
+@@ -1931,6 +1931,85 @@ free_interfaces:
        if (cp->string == NULL &&
                        !(dev->quirks & USB_QUIRK_CONFIG_INTF_STRINGS))
                cp->string = usb_cache_string(dev, cp->desc.iConfiguration);
index 43614633dd8219bcf05ecb06ee3949196c4b27ba..338bbea5539e62edb79f3208d8bbd3e8139a5344 100644 (file)
@@ -233,7 +233,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                return -ENOMEM;
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -2730,6 +2730,8 @@ static const struct file_operations proc
+@@ -2740,6 +2740,8 @@ static const struct file_operations proc
  
  static int __init proc_vmalloc_init(void)
  {
@@ -394,7 +394,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/ipv4/route.c
 +++ b/net/ipv4/route.c
-@@ -423,6 +423,9 @@ static struct pernet_operations ip_rt_pr
+@@ -421,6 +421,9 @@ static struct pernet_operations ip_rt_pr
  
  static int __init ip_rt_proc_init(void)
  {
index 5e67c891c2c49e5350f156390904cc7be93487b1..d029b7cc6c048061f879470fd74280f3c0defed8 100644 (file)
@@ -156,7 +156,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        int ret;
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -4454,6 +4454,14 @@ hub_port_init(struct usb_hub *hub, struc
+@@ -4468,6 +4468,14 @@ hub_port_init(struct usb_hub *hub, struc
        else
                speed = usb_speed_string(udev->speed);