kernel: Update kernel 4.14 to version 4.14.202
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 16 Oct 2020 21:33:22 +0000 (23:33 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Oct 2020 22:32:31 +0000 (00:32 +0200)
Compile and runtime tested on x86/64.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
17 files changed:
include/kernel-version.mk
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/backport-4.14/320-v4.16-netfilter-nf_conntrack-add-IPS_OFFLOAD-status-bit.patch
target/linux/generic/hack-4.14/700-swconfig_switch_drivers.patch
target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch
target/linux/generic/hack-4.14/721-phy_packets.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/generic/pending-4.14/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
target/linux/generic/pending-4.14/460-mtd-cfi_cmdset_0002-no-erase_suspend.patch
target/linux/generic/pending-4.14/461-mtd-cfi_cmdset_0002-add-buffer-write-cmd-timeout.patch
target/linux/generic/pending-4.14/630-packet_socket_type.patch
target/linux/generic/pending-4.14/655-increase_skb_pad.patch
target/linux/generic/pending-4.14/834-ledtrig-libata.patch
target/linux/ipq40xx/patches-4.14/700-net-add-qualcomm-mdio-and-phy.patch
target/linux/mediatek/patches-4.14/0052-net-phy-add-FC.patch
target/linux/oxnas/patches-4.14/999-libata-hacks.patch
target/linux/ramips/patches-4.14/0037-mtd-cfi-cmdset-0002-force-word-write.patch

index a4532b764e6f768ee8c600335d8ce1b28d53ee13..bdcd01686c43ec2e664306ce1c05e015fbec8424 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .240
-LINUX_VERSION-4.14 = .199
+LINUX_VERSION-4.14 = .202
 
 LINUX_KERNEL_HASH-4.9.240 = 06e470c66988da200ae95dc5d5fdfd1e1f8611e8c3445620e3566ecd0bdf776f
-LINUX_KERNEL_HASH-4.14.199 = 02f3432a262b3804745501f8c3c51d735133af48a39909df8b031d0b9653d4f9
+LINUX_KERNEL_HASH-4.14.202 = 95c717ab5b0bdd2333e829f0507385fbe3424ceee810727f3a8551a0c74be328
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index ab6a8f337429698906e815d455873b063d2ad842..ebd90a8ef2e400f259496092ecea6bec88ff9b0c 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1996,7 +1996,8 @@ static const struct usb_device_id option
+@@ -2001,7 +2001,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index 885d632d22db4d56ce668cc45525aa17b0c086e9..6390cc4f2b1c50e7ae81e7456b00c6edb890f764 100644 (file)
@@ -90,7 +90,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                                expired_count++;
 --- a/net/netfilter/nf_conntrack_netlink.c
 +++ b/net/netfilter/nf_conntrack_netlink.c
-@@ -1123,6 +1123,14 @@ static const struct nla_policy ct_nla_po
+@@ -1125,6 +1125,14 @@ static const struct nla_policy ct_nla_po
                                    .len = NF_CT_LABELS_MAX_SIZE },
  };
  
@@ -105,7 +105,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static int ctnetlink_flush_conntrack(struct net *net,
                                     const struct nlattr * const cda[],
                                     u32 portid, int report)
-@@ -1135,7 +1143,7 @@ static int ctnetlink_flush_conntrack(str
+@@ -1137,7 +1145,7 @@ static int ctnetlink_flush_conntrack(str
                        return PTR_ERR(filter);
        }
  
@@ -114,7 +114,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                                  portid, report);
        kfree(filter);
  
-@@ -1181,6 +1189,11 @@ static int ctnetlink_del_conntrack(struc
+@@ -1183,6 +1191,11 @@ static int ctnetlink_del_conntrack(struc
  
        ct = nf_ct_tuplehash_to_ctrack(h);
  
index 0ec197fbb00cc4fb4e1c728a0b092ea074805ddd..d98d082db16519d85bae11f864b0b2321c68844e 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -198,6 +198,89 @@ config LED_TRIGGER_PHY
+@@ -199,6 +199,89 @@ config LED_TRIGGER_PHY
                <Speed in megabits>Mbps or <Speed in gigabits>Gbps
  
  
index 5885c8fae6953b6d0a049f07e797107316d3f1bb..c45183a104689f131853331851741acc5c117a0f 100644 (file)
@@ -15,7 +15,7 @@
  
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1466,6 +1466,9 @@ int genphy_update_link(struct phy_device
+@@ -1467,6 +1467,9 @@ int genphy_update_link(struct phy_device
  {
        int status;
  
index e6e06554de10214701dc04db6e8ac8c6b25a7dc8..93d63534eb66ccbe3b67a1183b243076403b64ce 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
   */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2532,6 +2532,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -2544,6 +2544,10 @@ static inline int pskb_trim(struct sk_bu
        return (len < skb->len) ? __pskb_trim(skb, len) : 0;
  }
  
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  /**
   *    pskb_trim_unique - remove end from a paged unique (not cloned) buffer
   *    @skb: buffer to alter
-@@ -2663,16 +2667,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2675,16 +2679,6 @@ static inline struct sk_buff *dev_alloc_
  }
  
  
index 73144afb2f0f43331552bc26083d7e0ab47f6c5b..dd4765d5b815a0d299e7dad57492aac8dbfcb39c 100644 (file)
@@ -394,7 +394,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/ipv4/route.c
 +++ b/net/ipv4/route.c
-@@ -426,6 +426,9 @@ static struct pernet_operations ip_rt_pr
+@@ -427,6 +427,9 @@ static struct pernet_operations ip_rt_pr
  
  static int __init ip_rt_proc_init(void)
  {
index 53b1a9a13c42a1d4804e56ae9e831ac27c1ff4b2..c6f82991e10bcf337fdc67b53db3b69aaef9addf 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -6151,7 +6151,7 @@ static void __ref alloc_node_mem_map(str
+@@ -6152,7 +6152,7 @@ static void __ref alloc_node_mem_map(str
                mem_map = NODE_DATA(0)->node_mem_map;
  #if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
                if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
index 41f9d31cb0a33c5869ac6e75cf49dab0505b001c..3d39d3731db86ae6cf5c67f03a5181529e2570fa 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -811,7 +811,7 @@ static int get_chip(struct map_info *map
+@@ -810,7 +810,7 @@ static int get_chip(struct map_info *map
                return 0;
  
        case FL_ERASING:
index 932f219cf2963053d67bdf7d31ebb6c19f9b37da..1b07791ecafd8adb9dee035aef68307152103f4d 100644 (file)
@@ -7,7 +7,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
  1 file changed, 1 insertion(+)
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1839,6 +1839,7 @@ static int __xipram do_write_buffer(stru
+@@ -1838,6 +1838,7 @@ static int __xipram do_write_buffer(stru
  
        /* Write Buffer Load */
        map_write(map, CMD(0x25), cmd_adr);
index 36405692139340ffeefc370ac45c6414e234fdcf..e9b40b18c62067923e7b50a96ab7658d6c8bd4a5 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -2216,12 +2218,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -2217,12 +2219,12 @@ static int tpacket_rcv(struct sk_buff *s
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
  
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3318,6 +3320,7 @@ static int packet_create(struct net *net
+@@ -3325,6 +3327,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3940,6 +3943,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3947,6 +3950,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3992,6 +4005,13 @@ static int packet_getsockopt(struct sock
+@@ -3999,6 +4012,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index fa47fe62a80cde13e35017765c5d9c769f638c8c..bccce61083ccb0244c2076766c2e6ef179849335 100644 (file)
@@ -9,7 +9,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2496,7 +2496,7 @@ static inline int pskb_network_may_pull(
+@@ -2508,7 +2508,7 @@ static inline int pskb_network_may_pull(
   * NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
   */
  #ifndef NET_SKB_PAD
index 42e84c9a0a5abd16a8d61f53a8ac06784eba8d40..e3fd88f6b0627d6ab1df050cf5f1b44cdcb0b9d9 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -5122,6 +5135,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5125,6 +5138,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -6023,6 +6039,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6028,6 +6044,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -6044,6 +6063,12 @@ static void ata_host_release(struct devi
+@@ -6049,6 +6068,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6490,7 +6515,23 @@ int ata_host_register(struct ata_host *h
+@@ -6495,7 +6520,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
@@ -134,7 +134,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -894,6 +897,12 @@ struct ata_port {
+@@ -895,6 +898,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
index c6e715510eaa42c904d3cf1e7b31bc6024464381..593304a028d411d6520d5cdb7cf2c7b95b84c262 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH 30/38] NET: add qualcomm mdio and PHY
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -481,6 +481,20 @@ config XILINX_GMII2RGMII
+@@ -482,6 +482,20 @@ config XILINX_GMII2RGMII
          the Reduced Gigabit Media Independent Interface(RGMII) between
          Ethernet physical media devices and the Gigabit Ethernet controller.
  
index 46427a1d031af6b7b5c6dc85d251e4cbe2c686fc..a2ce9dcd8457aae48bb18b323d500a354f28170f 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1948,7 +1948,7 @@ static struct phy_driver genphy_driver =
+@@ -1949,7 +1949,7 @@ static struct phy_driver genphy_driver =
        .config_init    = genphy_config_init,
        .features       = PHY_GBIT_FEATURES | SUPPORTED_MII |
                          SUPPORTED_AUI | SUPPORTED_FIBRE |
index 0fb79dfaa82d80a623fc2399626628b4bff70637..d5c425b877486879fd16662978a6b6a3ced48043 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -5129,6 +5137,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5132,6 +5140,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -5174,6 +5185,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -5177,6 +5188,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);
@@ -36,8 +36,8 @@
  
 --- a/include/linux/libata.h
 +++ b/include/linux/libata.h
-@@ -923,6 +923,8 @@ struct ata_port_operations {
-       void (*qc_prep)(struct ata_queued_cmd *qc);
+@@ -924,6 +924,8 @@ struct ata_port_operations {
+       enum ata_completion_errors (*qc_prep)(struct ata_queued_cmd *qc);
        unsigned int (*qc_issue)(struct ata_queued_cmd *qc);
        bool (*qc_fill_rtf)(struct ata_queued_cmd *qc);
 +      int (*qc_new)(struct ata_port *ap);
@@ -45,7 +45,7 @@
  
        /*
         * Configuration and exception handling
-@@ -1013,6 +1015,9 @@ struct ata_port_operations {
+@@ -1014,6 +1016,9 @@ struct ata_port_operations {
        void (*phy_reset)(struct ata_port *ap);
        void (*eng_timeout)(struct ata_port *ap);
  
index 39717bbad48e4654c6168640c6deeac1217cf56b..4f44aed3abc24ba6afada858831bd6e751ef7ee6 100644 (file)
@@ -44,7 +44,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
  
  /* Atmel chips don't use the same PRI format as AMD chips */
  static void fixup_convert_atmel_pri(struct mtd_info *mtd)
-@@ -1798,6 +1802,7 @@ static int cfi_amdstd_write_words(struct
+@@ -1797,6 +1801,7 @@ static int cfi_amdstd_write_words(struct
  /*
   * FIXME: interleaved mode not tested, and probably not supported!
   */
@@ -52,7 +52,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
  static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
                                    unsigned long adr, const u_char *buf,
                                    int len)
-@@ -1930,7 +1935,6 @@ static int __xipram do_write_buffer(stru
+@@ -1929,7 +1934,6 @@ static int __xipram do_write_buffer(stru
        return ret;
  }
  
@@ -60,7 +60,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
  static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
                                    size_t *retlen, const u_char *buf)
  {
-@@ -2005,6 +2009,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -2004,6 +2008,7 @@ static int cfi_amdstd_write_buffers(stru
  
        return 0;
  }