ramips: mt76x8: enable small_flash feature
authorTomasz Maciej Nowak <tmn505@gmail.com>
Wed, 10 Jan 2024 15:59:48 +0000 (16:59 +0100)
committerSander Vanheule <sander@svanheule.net>
Mon, 22 Jan 2024 11:32:23 +0000 (12:32 +0100)
Some of devices in this target have only 8 MiB space and are closing to
borders of usable space. Particularly, TP-Link RE305 v1 already suffers
from this issue[1], where with current partition layout, on release
images, there's not enough space for overlay. So activate small_flash
feature, which will remove some userspace hardening but will gain almost
1 MiB additional flash memory space. Here is small size comparison of
similar device (RE365 v1) with default config + LuCI:

kernel rootfs sysupgrade
current: 2305728 3635044 5964584
small_flash: 1713571 3320132 5047080

1. https://github.com/openwrt/openwrt/issues/14215

Suggested-by: Sander Vanheule <sander@svanheule.net>
Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
target/linux/ramips/mt76x8/target.mk

index 862736cb2f38c896e302b2e845c57181b8163108..cfc2655cac182861d9b42c9b80867ccbd9a2a32f 100644 (file)
@@ -4,7 +4,7 @@
 
 SUBTARGET:=mt76x8
 BOARDNAME:=MT76x8 based boards
-FEATURES+=usb ramdisk
+FEATURES+=usb ramdisk small_flash
 CPU_TYPE:=24kc
 
 DEFAULT_PACKAGES += kmod-mt7603 wpad-basic-mbedtls swconfig