jansson: cleanup and switch to codeload.github.com
authorNick Hainke <vincent@systemli.org>
Sun, 3 Jul 2022 19:04:23 +0000 (21:04 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 10 Jul 2022 17:07:47 +0000 (19:07 +0200)
- Rearrange Makefile.
- Switch to codeload.github.com because it looks like new version are
  not longer deployed at www.digip.org

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/libs/jansson/Makefile

index 5799a362dd5f01962d826babddcaea25f972fa7e..07bab58a54e365e9ac922807167c59b0ce57aa84 100644 (file)
@@ -10,13 +10,14 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=jansson
 PKG_VERSION:=2.13.1
 PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/akheron/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=f22901582138e3203959c9257cf83eba9929ac41d7be4a42557213a22ebcc7a0
+
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.digip.org/jansson/releases/
-PKG_HASH:=ee90a0f879d2b7b7159124ff22b937a2a9a8c36d3bb65d1da7dd3f04370a10bd
-
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk