mediatek: bpi-r64: make initramfs/recovery optional
authorDaniel Golle <daniel@makrotopia.org>
Thu, 8 Sep 2022 01:44:30 +0000 (02:44 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 18 Sep 2022 14:39:41 +0000 (15:39 +0100)
Only include recovery image in SD card image generated for the
BananaPi BPi-R64 if building with CONFIG_TARGET_ROOTFS_INITRAMFS
This allows to build images larger than 32 MB (the limit for
initramfs/recovery image) by deselecting initramfs.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit 50c892d67bb4af90861be9fbb6831c2eeb62de11)

target/linux/mediatek/image/mt7622.mk

index 8ec58ff7760ff72fb3b82ca3371d6abb8d1a5e8e..ffcc3e564e2a422a91d4cb64ada5dca0635aee7d 100644 (file)
@@ -86,13 +86,18 @@ define Device/bananapi_bpi-r64
   ARTIFACT/sdcard.img.gz       := mt7622-gpt sdmmc |\
                                   pad-to 512k | bl2 sdmmc-2ddr |\
                                   pad-to 2048k | bl31-uboot bananapi_bpi-r64-sdmmc |\
-                                  pad-to 6144k | append-image-stage initramfs-recovery.itb |\
+                               $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),\
+                                  pad-to 6144k | append-image-stage initramfs-recovery.itb | checksize 38912k |\
+                               ) \
                                   pad-to 38912k | mt7622-gpt emmc |\
                                   pad-to 39424k | bl2 emmc-2ddr |\
                                   pad-to 40960k | bl31-uboot bananapi_bpi-r64-emmc |\
                                   pad-to 43008k | bl2 snand-2ddr |\
                                   pad-to 43520k | bl31-uboot bananapi_bpi-r64-snand |\
-                                  pad-to 46080k | append-image squashfs-sysupgrade.itb | gzip
+                               $(if $(CONFIG_TARGET_ROOTFS_SQUASHFS),\
+                                  pad-to 46080k | append-image squashfs-sysupgrade.itb | check-size | gzip \
+                               )
+  IMAGE_SIZE := $$(shell expr 45 + $$(CONFIG_TARGET_ROOTFS_PARTSIZE))m
   KERNEL                       := kernel-bin | gzip
   KERNEL_INITRAMFS             := kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb with-initrd | pad-to 128k
   IMAGE/sysupgrade.itb         := append-kernel | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb external-static-with-rootfs | append-metadata