update_kernel.sh: update it to new kernel hash/version file way
authorAnsuel Smith <ansuelsmth@gmail.com>
Sun, 16 Jan 2022 20:35:32 +0000 (21:35 +0100)
committerRui Salvaterra <rsalvaterra@gmail.com>
Sun, 16 Jan 2022 23:53:36 +0000 (23:53 +0000)
OpenWrt changed how the hash/version of the various kernels are declared and
saved.
They are now placed in dedicated files. Fix the update_kernel.sh script to
update the kernel version/hash in the correct file.

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
[fix typos/wrapping]
Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
update_kernel.sh

index 0cbdb1d28f0b9466d528ddaa2a7b8ec7aa95a117..2c4bb09469f89bd3cbfebb67d1dd999236dd81d0 100755 (executable)
@@ -155,7 +155,7 @@ if [ "$UPDATE" -eq 1 ]; then
                CHECKSUM=$(./staging_dir/host/bin/mkhash sha256 dl/linux-$PATCHVER.tar.xz)
        fi
 
-       $CMD ./staging_dir/host/bin/sed -i include/kernel-version.mk \
+       $CMD ./staging_dir/host/bin/sed -i include/kernel-${KERNEL} \
                -e "s|LINUX_VERSION-${KERNEL} =.*|LINUX_VERSION-${KERNEL} = ${NEWVER}|" \
                -e "s|LINUX_KERNEL_HASH-${KERNEL}.*|LINUX_KERNEL_HASH-${PATCHVER} = ${CHECKSUM}|"
 fi