asterisk-13.x: bump to 13.18.5
authorSebastian Kemper <sebastian_ml@gmx.net>
Tue, 16 Jan 2018 18:48:31 +0000 (19:48 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Tue, 16 Jan 2018 18:48:34 +0000 (19:48 +0100)
The currently used version 13.9.1 has the following open CVEs:

CVE-2016-7551
CVE-2016-9938
CVE-2017-14099
CVE-2017-14100
CVE-2017-14603
CVE-2017-16671
CVE-2017-16672
CVE-2017-17090
CVE-2017-17664
CVE-2017-17850
CVE-2017-7617
CVE-2017-9358
CVE-2017-17850

Upstream provided patches for these but used 13.13.0 or later versions
as baseline. Multiple of these patches fail to apply to 13.9.1. So
upgrade to the current version instead.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/asterisk-13.x/Makefile
net/asterisk-13.x/patches/001-disable-semaphores-check.patch
net/asterisk-13.x/patches/002-undef-res-ninit.patch
net/asterisk-13.x/patches/004-ifdef-missing-execinfo.patch
net/asterisk-13.x/patches/040-fix-config-options.patch [deleted file]
net/asterisk-13.x/patches/051-musl-includes.patch [deleted file]
net/asterisk-13.x/patches/052-musl-libcap.patch

index 5cf80cf6f227dedea1b132d6561358a7dd704e35..ac605e2b70a73bc885ad0b056995b18f95d52395 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk13
-PKG_VERSION:=13.9.1
+PKG_VERSION:=13.18.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://downloads.asterisk.org/pub/telephony/asterisk/releases/
-PKG_MD5SUM:=76c42992a79f41ec467ed20500e8b249
+PKG_SOURCE_URL:=https://downloads.asterisk.org/pub/telephony/asterisk/releases/
+PKG_MD5SUM:=4ad2a5ab1dd12cba5f37fca52961aa2a
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/asterisk-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=libxml2/host
@@ -217,7 +217,6 @@ CONFIGURE_ARGS+= \
        --without-tds \
        --without-termcap \
        --without-tinfo \
-       --with-uuid="$(STAGING_DIR)/usr" \
        --without-vorbis \
        --without-vpb \
        --with-z="$(STAGING_DIR)/usr" \
index 6256fd8c575f67e86f30abc82208016acc5f2e9a..ba36dc7505b136e42e46c74544d50fb9a50084ce 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -927,19 +927,6 @@ AC_LINK_IFELSE(
+@@ -963,19 +963,6 @@ AC_LINK_IFELSE(
    ]
  )
  
index 1d01bb8297d310fe15ff776a138e2da3641066d5..110c07e6425355a331e54014f7b102ae18d6a488 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1261,7 +1261,6 @@ AC_LINK_IFELSE(
+@@ -1290,7 +1290,6 @@ AC_LINK_IFELSE(
                        #include <resolv.h>],
                        [int foo = res_ninit(NULL);])],
        AC_MSG_RESULT(yes)
index 264eb41a7b406c380c19cb76b28b39b2491c9406..0a03b3874551ab31543c2a6c16395c895f080045 100644 (file)
@@ -31,7 +31,7 @@
 @@ -114,9 +120,11 @@ struct ast_lock_track {
        int reentrancy;
        const char *func[AST_MAX_REENTRANCY];
-       pthread_t thread[AST_MAX_REENTRANCY];
+       pthread_t thread_id[AST_MAX_REENTRANCY];
 +#ifndef __UCLIBC__
  #ifdef HAVE_BKTR
        struct ast_bt backtrace[AST_MAX_REENTRANCY];
diff --git a/net/asterisk-13.x/patches/040-fix-config-options.patch b/net/asterisk-13.x/patches/040-fix-config-options.patch
deleted file mode 100644 (file)
index e3ed33a..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/main/config_options.c
-+++ b/main/config_options.c
-@@ -198,8 +198,8 @@ static int link_option_to_types(struct a
- #ifdef AST_DEVMODE
-                       opt->doc_unavailable = 1;
- #endif
--#endif
-               }
-+#endif
-       }
-       /* The container(s) should hold the only ref to opt */
-       ao2_ref(opt, -1);
diff --git a/net/asterisk-13.x/patches/051-musl-includes.patch b/net/asterisk-13.x/patches/051-musl-includes.patch
deleted file mode 100644 (file)
index 6bee31c..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/include/asterisk/compat.h
-+++ b/include/asterisk/compat.h
-@@ -68,7 +68,7 @@
- #endif
- #ifndef AST_POLL_COMPAT
--#include <sys/poll.h>
-+#include <poll.h>
- #else
- #include "asterisk/poll-compat.h"
- #endif
---- a/include/asterisk/poll-compat.h
-+++ b/include/asterisk/poll-compat.h
-@@ -83,7 +83,7 @@
- #ifndef AST_POLL_COMPAT
--#include <sys/poll.h>
-+#include <poll.h>
- #define ast_poll(a, b, c) poll(a, b, c)
---- a/main/ast_expr2.c
-+++ b/main/ast_expr2.c
-@@ -93,6 +93,7 @@
- #include "asterisk.h"
-+#include <sys/cdefs.h>
- #include <sys/types.h>
- #include <stdio.h>
---- a/main/ast_expr2.y
-+++ b/main/ast_expr2.y
-@@ -14,6 +14,7 @@
- #include "asterisk.h"
-+#include <sys/cdefs.h>
- #include <sys/types.h>
- #include <stdio.h>
index 41981ca17fc655b352b1641b46066e67e2a3ac6d..c50d24ede6c83e917e35fee131ec43bd1850a3c9 100644 (file)
@@ -1,7 +1,7 @@
 --- a/configure.ac
 +++ b/configure.ac
 @@ -181,6 +181,9 @@ case "${host_os}" in
-      linux-gnueabi* |  linux-gnuspe)
+      linux-gnu*)
       OSARCH=linux-gnu
       ;;
 +     linux-musl*)
@@ -10,7 +10,7 @@
       kfreebsd*-gnu)
       OSARCH=kfreebsd-gnu
       ;;
-@@ -1373,9 +1376,11 @@ if test "${PBX_BFD}" = "0"; then
+@@ -1414,9 +1417,11 @@ if test "${PBX_BFD}" = "0"; then
    AST_EXT_LIB_CHECK([BFD], [bfd], [bfd_check_format], [bfd.h], [-ldl -liberty -lz])
  fi
  
  AST_C_DEFINE_CHECK([DAHDI], [DAHDI_DEFAULT_MTU_MRU], [dahdi/user.h], [220])
 --- a/main/Makefile
 +++ b/main/Makefile
-@@ -45,7 +45,7 @@ AST_LIBS+=$(UUID_LIB)
- AST_LIBS+=$(CRYPT_LIB)
- AST_LIBS+=$(AST_CLANG_BLOCKS_LIBS)
+@@ -47,7 +47,7 @@ AST_LIBS+=$(AST_CLANG_BLOCKS_LIBS)
+ AST_LIBS+=$(RT_LIB)
+ AST_LIBS+=$(SYSTEMD_LIB)
  
 -ifneq ($(findstring $(OSARCH), linux-gnu uclinux linux-uclibc kfreebsd-gnu),)
 +ifneq ($(findstring $(OSARCH), linux-gnu uclinux linux-uclibc linux-musl kfreebsd-gnu),)
-   ifneq ($(findstring LOADABLE_MODULES,$(MENUSELECT_CFLAGS)),)
    AST_LIBS+=-ldl
-   endif
+   ifneq (x$(CAP_LIB),x)
+     AST_LIBS+=$(CAP_LIB)