libwebsockets: fix recursive dependency
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Wed, 26 Oct 2022 07:12:38 +0000 (09:12 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Thu, 27 Oct 2022 12:48:20 +0000 (14:48 +0200)
While running `make menuconfig`, it was discovered then there is a
recursive dependency like this:
tmp/.config-package.in:59138:error: recursive dependency detected!
tmp/.config-package.in:59138: symbol PACKAGE_libwebsockets-openssl is selected by PACKAGE_libwebsockets-mbedtls
tmp/.config-package.in:59122: symbol PACKAGE_libwebsockets-mbedtls depends on PACKAGE_libwebsockets-openssl

It is not possible with the recently added conflicts that two packages
(OpenSSL and full variant, which uses OpenSSL as well), which are almost the same
provides the same named package libwebsockets as their conflict - Mbed
TLS.

Fixes: 676c5c72b5eeb583da2603e399fac085fa442c59 ("libwebsockets: OpenSSL
and mbedTLS variants should conflict")

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
(cherry picked from commit a4e8cbb89a48729b3c3ad615765549628d495b0f)

libs/libwebsockets/Makefile

index 80c52d74a137a5c84ffdf201a20d39794b82812d..66eabd4bc20e37648720882e0eccb5c2c79888ec 100644 (file)
@@ -43,7 +43,6 @@ define Package/libwebsockets/Default
        DEPENDS:=+zlib +libcap
        URL:=https://libwebsockets.org
        MAINTAINER:=Karl Palsson <karlp@etactica.com>
-       PROVIDES:= libwebsockets
 endef
 
 define Package/libwebsockets-openssl
@@ -59,6 +58,7 @@ define Package/libwebsockets-mbedtls
        TITLE += (mbedTLS)
        DEPENDS += +libmbedtls
        VARIANT:=mbedtls
+       PROVIDES:=libwebsockets
        CONFLICTS:=libwebsockets-openssl
 endef
 
@@ -67,7 +67,7 @@ define Package/libwebsockets-full
        TITLE += (Full - OpenSSL, libuv, plugins, CGI)
        DEPENDS += +libopenssl +libuv
        VARIANT:=full
-       PROVIDES:=libwebsockets-openssl
+       PROVIDES:=libwebsockets libwebsockets-openssl
 endef
 
 ifeq ($(BUILD_VARIANT),openssl)