flashrom: strip leading whitespace from PROGRAMMER_ARGS
authorFederico Capoano <f.capoano@openwisp.io>
Tue, 19 Mar 2024 13:52:31 +0000 (10:52 -0300)
committerTianling Shen <cnsztl@gmail.com>
Sat, 4 May 2024 11:07:15 +0000 (19:07 +0800)
Newer version of meson do not allow empty arguments.

Signed-off-by: Federico Capoano <f.capoano@openwisp.io>
utils/flashrom/Makefile
utils/flashrom/flashrom.mk

index e75add75ed038b58edcf159c65f33cc3dcd3a28e..cced9a846e664cbf8647542e5647a8ac38def8cb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flashrom
 PKG_VERSION:=1.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.flashrom.org/releases
index 5ee91a8f063dc86184eec21d6669b8a88c104db7..454e954436d0a65a2eede0571f52b47141656662 100644 (file)
@@ -96,9 +96,8 @@ else
   $(eval $(call Programmer,satamv,$(FLASHROM_PCI)))
 endif
 
-comma := ,
 MESON_ARGS += \
        -Ddefault_programmer_name=$(DEFAULT_PROGRAMMER_NAME) \
-       -Dprogrammer=$(subst $() $(),$(comma),$(PROGRAMMER_ARGS)) \
+       -Dprogrammer=$(subst $(space),$(comma),$(strip $(PROGRAMMER_ARGS))) \
        -Dwerror=false \
        -Dtests=disabled