net-tools: Revert "net-tools: add netstat utiltiy"
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 8 May 2024 06:18:05 +0000 (08:18 +0200)
committerFlorian Eckert <fe@dev.tdt.de>
Wed, 8 May 2024 06:18:05 +0000 (08:18 +0200)
This reverts commit d932a867e9445a54e49ecbff4e07bb2d1d0197be as this
changes has not been reviewed and must be reverted.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
net/net-tools/Makefile

index 60ff0fb2da50c7f35f2ae1346e4542e59ad828d1..306b0d5df0893e3df815e60efacd9c01dcdb022f 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=net-tools
 PKG_VERSION:=2.10
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://sourceforge.net/projects/net-tools/files/
@@ -53,22 +53,6 @@ define Package/net-tools-route/description
        functionality of the net-tools variant (e.g. AF_X25).
 endef
 
-define Package/net-tools-netstat
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=net-tools - netstat utility
-  URL:=http://net-tools.sourceforge.net/
-  PROVIDES:=route
-  ALTERNATIVES:=300:/bin/netstat:/usr/libexec/net-tools-netstat
-endef
-
-define Package/net-tools-netstat/description
-       Replace busybox version of the netstat command with the full net-tools
-       version. This is normally not needed as busybox is smaller and provides
-       sufficient functionality, but some users may want or need the full
-       functionality of the net-tools variant.
-endef
-
 define Build/Configure
        # Failed configure.sh leaves stub config.h around.
        rm -f $(PKG_BUILD_DIR)/config.h
@@ -85,11 +69,5 @@ define Package/net-tools-route/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/route $(1)/usr/libexec/net-tools-route
 endef
 
-define Package/net-tools-netstat/install
-       $(INSTALL_DIR) $(1)/usr/libexec
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/netstat $(1)/usr/libexec/net-tools-netstat
-endef
-
 $(eval $(call BuildPackage,mii-tool))
 $(eval $(call BuildPackage,net-tools-route))
-$(eval $(call BuildPackage,net-tools-netstat))