ffmpeg: update to 5.1
authorJohn Audia <therealgraysky@proton.me>
Sat, 23 Jul 2022 10:28:46 +0000 (06:28 -0400)
committerRosen Penev <rosenp@gmail.com>
Thu, 28 Jul 2022 21:18:16 +0000 (14:18 -0700)
Bump to latest upstream version, manually rebased: 050-glibc.patch

Tested using:
ffmpeg -f lavfi -i testsrc=duration=10:size=1280x720:rate=30 testsrc.mpg

Resulting mpg was good.

Build system: x86_64
Build-tested: bcm2711/RPi4B
Run-tested: bcm2711/RPi4B

Signed-off-by: John Audia <therealgraysky@proton.me>
multimedia/ffmpeg/Makefile
multimedia/ffmpeg/patches/050-glibc.patch

index b7e1ae437c63b5240923d8023edb10f33be68f66..bc4b4a91ae362c0e09d3475ee33435798db7fe5a 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffmpeg
-PKG_VERSION:=5.0.1
+PKG_VERSION:=5.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://ffmpeg.org/releases/
-PKG_HASH:=ef2efae259ce80a240de48ec85ecb062cecca26e4352ffb3fda562c21a93007b
+PKG_HASH:=55eb6aab5ee235550fa54a33eaf8bf1b4ec66c01453182b12f6a993d75698b03
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
                Ian Leonard <antonlacon@gmail.com>
 
index c4f0dda724b399e2098ba94fa35d3562b592cbc7..25eba2aea0b0ca061022a73df6546d5743424a25 100644 (file)
@@ -1,10 +1,11 @@
 --- a/libavcodec/wmv2dsp.c
 +++ b/libavcodec/wmv2dsp.c
-@@ -264,6 +264,6 @@ av_cold void ff_wmv2dsp_init(WMV2DSPCont
+@@ -264,7 +264,7 @@ av_cold void ff_wmv2dsp_init(WMV2DSPCont
      c->put_mspel_pixels_tab[6] = put_mspel8_mc22_c;
      c->put_mspel_pixels_tab[7] = put_mspel8_mc32_c;
  
--    if (ARCH_MIPS)
-+    if (ARCH_MIPS64)
-         ff_wmv2dsp_init_mips(c);
+-#if ARCH_MIPS
++#if ARCH_MIPS64
+     ff_wmv2dsp_init_mips(c);
+ #endif
  }