kernel: bump 4.14 to 4.14.172
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 9 Mar 2020 10:52:40 +0000 (11:52 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 9 Mar 2020 19:45:11 +0000 (20:45 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/apm821xx/patches-4.14/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
target/linux/apm821xx/patches-4.14/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/ipq40xx/patches-4.14/307-ARM-qcom-Add-IPQ4019-SoC-support.patch
target/linux/ipq806x/patches-4.14/0060-HACK-arch-arm-force-ZRELADDR-on-arch-qcom.patch
target/linux/ipq806x/patches-4.14/0067-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/mediatek/patches-4.14/0191-usb-xhci-allow-imod-interval-to-be-configurable.patch
target/linux/mvebu/patches-4.14/006-mvebu-Mangle-bootloader-s-kernel-arguments.patch
target/linux/oxnas/patches-4.14/996-generic-Mangle-bootloader-s-kernel-arguments.patch

index 16a7ab31a2e44b704504ed18bdc7d4ff81e3d039..b20573dd00e94801ab8bfbb45fd9af3a27e9578c 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .215
-LINUX_VERSION-4.14 = .171
+LINUX_VERSION-4.14 = .172
 
 LINUX_KERNEL_HASH-4.9.215 = 236f2f47853700f22b9925cb17917d97ff7120fcc8110ec827c5a030a8129f48
-LINUX_KERNEL_HASH-4.14.171 = 4fe02489e4b4a187eccf0ef87df6100534c9d485e76d876b1fa247c7635332a0
+LINUX_KERNEL_HASH-4.14.172 = 2318a1ab937580a079351ed20557c336a3d95b664f667b14e3ba49e3271b217a
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 41f9c8ac7db22af61fda06ae273159cd75d96232..202078aa8683b10e8719750749ff8ddb9361a2de 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  
  #include "xhci.h"
  #include "xhci-trace.h"
-@@ -266,6 +268,458 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -268,6 +270,458 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -503,7 +503,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -301,6 +755,22 @@ static int xhci_pci_probe(struct pci_dev
+@@ -306,6 +760,22 @@ static int xhci_pci_probe(struct pci_dev
        struct hc_driver *driver;
        struct usb_hcd *hcd;
  
@@ -526,7 +526,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
        driver = (struct hc_driver *)id->driver_data;
  
        /* For some HW implementation, a XHCI reset is just not enough... */
-@@ -365,6 +835,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -367,6 +837,16 @@ static void xhci_pci_remove(struct pci_d
  {
        struct xhci_hcd *xhci;
  
index 47ae33062bcd146cad3002b97098fc9acd3e3e1c..c7315f9b8ba7d891d00b78a4275fa095bc4c1028 100644 (file)
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -219,7 +219,7 @@ static void xhci_pci_quirks(struct devic
+@@ -221,7 +221,7 @@ static void xhci_pci_quirks(struct devic
                xhci->quirks |= XHCI_TRUST_TX_LENGTH;
        if (pdev->vendor == PCI_VENDOR_ID_RENESAS &&
                        pdev->device == 0x0015)
index 511229bdbb176bd81001c63112783b22724ba7cc..b8e84aa1df8aa0f7855d13948846ca77d4df34ac 100644 (file)
@@ -189,7 +189,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
 --- a/kernel/irq/proc.c
 +++ b/kernel/irq/proc.c
-@@ -396,6 +396,9 @@ void register_irq_proc(unsigned int irq,
+@@ -418,6 +418,9 @@ void register_irq_proc(unsigned int irq,
        void __maybe_unused *irqp = (void *)(unsigned long) irq;
        char name [MAX_NAMELEN];
  
@@ -199,7 +199,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!root_irq_dir || (desc->irq_data.chip == &no_irq_chip))
                return;
  
-@@ -449,6 +452,9 @@ void unregister_irq_proc(unsigned int ir
+@@ -471,6 +474,9 @@ void unregister_irq_proc(unsigned int ir
  {
        char name [MAX_NAMELEN];
  
@@ -209,7 +209,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!root_irq_dir || !desc->dir)
                return;
  #ifdef CONFIG_SMP
-@@ -487,6 +493,9 @@ void init_irq_proc(void)
+@@ -509,6 +515,9 @@ void init_irq_proc(void)
        unsigned int irq;
        struct irq_desc *desc;
  
index 1dc1c97c72847f55a13429b2cc467fedd71dd82f..9e77e252aaf5591b62ad5e485667b249edd708e1 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
 
 --- a/arch/arm/Makefile
 +++ b/arch/arm/Makefile
-@@ -149,6 +149,7 @@ textofs-$(CONFIG_SA1111) := 0x00208000
+@@ -151,6 +151,7 @@ textofs-$(CONFIG_SA1111) := 0x00208000
  endif
  textofs-$(CONFIG_ARCH_MSM8X60) := 0x00208000
  textofs-$(CONFIG_ARCH_MSM8960) := 0x00208000
index f810f6ac464c61b1d2757c517aac12f9e5d41887..581761f58095d781e91488d7c953f88441134d4b 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
        select GENERIC_CLOCKEVENTS
 --- a/arch/arm/Makefile
 +++ b/arch/arm/Makefile
-@@ -255,9 +255,11 @@ MACHINE  := arch/arm/mach-$(word 1,$(mac
+@@ -257,9 +257,11 @@ MACHINE  := arch/arm/mach-$(word 1,$(mac
  else
  MACHINE  :=
  endif
index 5d3243ccb4dd6244ff912b590d9837e4421a2a5e..f0cc3ed509042ea29f361a62fdb54eeac79adcf8 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1939,6 +1939,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1934,6 +1934,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index d3cb19150d9105e1411701fb050e3a3660d84740..0f79fa4fd1085fac2de98578005622b79a326f85 100644 (file)
@@ -86,7 +86,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
        if (!xhci->shared_hcd) {
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -277,6 +277,9 @@ static int xhci_pci_setup(struct usb_hcd
+@@ -279,6 +279,9 @@ static int xhci_pci_setup(struct usb_hcd
        if (!xhci->sbrn)
                pci_read_config_byte(pdev, XHCI_SBRN_OFFSET, &xhci->sbrn);
  
index 8f11632d04a4de3810d9d42ceb07911ebf6bb644..4ef86edb6ab492ec9d7a505b4466d97b85230c81 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1939,6 +1939,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1934,6 +1934,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index d3b047f3c4f164feae8f90f5c3f82f8cf54f0588..a06825f7c87b4ff7361c8b7ebb8e1bdbb5205556 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1939,6 +1939,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1934,6 +1934,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.