tools: add libpopt host build
authorJo-Philipp Wich <jo@mein.io>
Fri, 23 Jun 2017 10:19:53 +0000 (12:19 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 14 Aug 2019 05:56:58 +0000 (07:56 +0200)
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
tools/popt/Makefile [new file with mode: 0644]
tools/popt/patches/900-autoconf-compat.patch [new file with mode: 0644]

diff --git a/tools/popt/Makefile b/tools/popt/Makefile
new file mode 100644 (file)
index 0000000..50524b6
--- /dev/null
@@ -0,0 +1,21 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=popt
+PKG_VERSION:=1.16
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://rpm5.org/files/popt
+PKG_HASH:=e728ed296fe9f069a0e005003c3d6b2dde3d9cad453422a10d6558616d304cc8
+
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+       --disable-nls \
+       --disable-rpath \
+       --enable-shared=no \
+       --without-libiconv-prefix \
+       --without-libintl-prefix
+
+$(eval $(call HostBuild))
diff --git a/tools/popt/patches/900-autoconf-compat.patch b/tools/popt/patches/900-autoconf-compat.patch
new file mode 100644 (file)
index 0000000..71a2cda
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -46,7 +46,7 @@ AC_GCC_TRADITIONAL
+ AC_SYS_LARGEFILE
+ AC_ISC_POSIX
+-AM_C_PROTOTYPES
++AC_C_PROTOTYPES
+ AC_CHECK_HEADERS(float.h fnmatch.h glob.h langinfo.h libintl.h mcheck.h unistd.h)
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -35,9 +35,10 @@ tdict_LDADD = $(usrlib_LTLIBRARIES)
+ noinst_SCRIPTS = testit.sh
+ TESTS_ENVIRONMENT = \
++TESTS_DIR="$(top_srcdir)" \
+ test1="$(top_builddir)/test1"
+-TESTS = $(top_srcdir)/testit.sh
++TESTS = testit.sh
+ include_HEADERS = popt.h