When openwrt toolchain uses eglibc (2.15) instead of uclibc, libevent2 build fails...
authorMirko Vogt <mirko@openwrt.org>
Mon, 6 Aug 2012 11:06:54 +0000 (11:06 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 6 Aug 2012 11:06:54 +0000 (11:06 +0000)
Package libevent2 is missing dependencies for the following libraries:
librt.so.1

Fix is to define
DEPENDS:=+USE_EGLIBC:librt
which adds the librt dependency only if the eglibc is used by toolchain.
Patch has been tested by building the libevent2 both with the the eglibc and
uclibc  openwrt toolchains.

Signed-off-by: Mika Laitio <mika.laitio@nokia.com>
SVN-Revision: 33007

libs/libevent2/Makefile

index 6271f236e80a7831673d164565d4505e41221b8a..8e628b87b41d0948dddefed2e0c2100719b6e493 100644 (file)
@@ -28,6 +28,7 @@ define Package/libevent2/Default
   CATEGORY:=Libraries
   TITLE:=Event notification
   URL:=http://www.monkey.org/~provos/libevent/
+  DEPENDS:=+USE_EGLIBC:librt
 endef
 
 define Package/libevent2/Default/description
@@ -81,7 +82,7 @@ endef
 define Package/libevent2-openssl
   $(call Package/libevent2/Default)
   TITLE+= OpenSSL library (version 2.0)
-  DEPENDS:=+libopenssl
+  DEPENDS+=+libopenssl
 endef
 
 define Package/libevent2-openssl/description
@@ -94,7 +95,7 @@ endef
 define Package/libevent2-pthreads
   $(call Package/libevent2/Default)
   TITLE+= Pthreads library (version 2.0)
-  DEPENDS:=+libpthread
+  DEPENDS+=+libpthread
 endef
 
 define Package/libevent2-pthreads/description