WIP realtek: rtl931x: add Netgear MS510TXM wip/ms510txm
authorSander Vanheule <sander@svanheule.net>
Tue, 24 Jan 2023 22:01:52 +0000 (23:01 +0100)
committerSander Vanheule <sander@svanheule.net>
Thu, 26 Jan 2023 19:00:06 +0000 (20:00 +0100)
target/linux/realtek/dts-5.15/rtl9313_netgear_ms510txm.dts [new file with mode: 0644]
target/linux/realtek/image/rtl931x.mk

diff --git a/target/linux/realtek/dts-5.15/rtl9313_netgear_ms510txm.dts b/target/linux/realtek/dts-5.15/rtl9313_netgear_ms510txm.dts
new file mode 100644 (file)
index 0000000..9f79031
--- /dev/null
@@ -0,0 +1,61 @@
+// SPDX-License-Identifier: GPL-2.0-or-later
+/dts-v1/;
+
+#include "rtl930x.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/leds/common.h>
+
+/ {
+       compatible = "netgear,ms510txm", "realtek,rtl9311-soc";
+       model = "Netgear MS510TXM";
+};
+
+&spi0 {
+       status = "okay";
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0xe0000>;
+                               read-only;
+                       };
+                       partition@e0000 {
+                               label = "u-boot-env";
+                               reg = <0xe0000 0x10000>;
+                       };
+                       partition@f0000 {
+                               label = "u-boot-env2";
+                               reg = <0xf0000 0x10000>;
+                               read-only;
+                       };
+                       partition@100000 {
+                               label = "jffs";
+                               reg = <0x100000 0x100000>;
+                       };
+                       partition@200000 {
+                               label = "jffs2";
+                               reg = <0x200000 0x100000>;
+                       };
+                       partition@b300000 {
+                               label = "firmware";
+                               reg = <0x300000 0xce0000>;
+                               compatible = "openwrt,uimage", "denx,uimage";
+                               openwrt,ih-magic = <0x45475020>;
+                       };
+                       partition@fe0000 {
+                               label = "log";
+                               reg = <0xfe0000 0x20000>;
+                       };
+               };
+       };
+};
index a4e40e534e6a84db241abfe5076962a90f8a71bd..4e02cedd7ea13683226d9a6d9cde0e291e2b5d5d 100644 (file)
@@ -1 +1,20 @@
 # SPDX-License-Identifier: GPL-2.0-only
+
+define Device/netgear_ms510txm
+  SOC := rtl9313
+  UIMAGE_MAGIC := 0x4e475020 # "NGP "
+  DEVICE_VENDOR := Netgear
+  DEVICE_MODEL := MS510TXM
+  IMAGE_SIZE := 14848k
+  KERNEL := \
+       kernel-bin | \
+       append-dtb | \
+       lzma | \
+       uImage lzma
+  KERNEL_INITRAMFS := \
+       kernel-bin | \
+       append-dtb | \
+       lzma | \
+       uImage lzma
+endef
+TARGET_DEVICES += netgear_ms510txm