build: fix warnings from grep
authorChris Osgood <chris_github@functionalfuture.com>
Thu, 15 Sep 2022 12:09:38 +0000 (08:09 -0400)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 29 Sep 2022 17:45:12 +0000 (19:45 +0200)
Fixes build warnings when using newer versions of grep.

Signed-off-by: Chris Osgood <chris_github@functionalfuture.com>
Tested-by: Georgi Valkov <gvalkov@gmail.com>
(cherry picked from commit c5e167e0d6075c46ca92c30b425c4dcb05fec5ed)
[ fix conflict error ]
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/sdk/files/Makefile

index 2f89ce0cf85cd5ca5ff6e09579a1e630684046e1..3d5d06a72788c281acc3e4ede4116c1e01e789c1 100644 (file)
@@ -14,7 +14,7 @@ export TOPDIR LC_ALL LANG SDK
 
 world:
 
-DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep -E '\/usr' | head -n 1)
+DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep '/usr' | head -n 1)
 export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
 
 ifneq ($(OPENWRT_BUILD),1)