ramips: mt7621: use lzma-loader for Sercomm NA502
authorSzabolcs Hubai <szab.hu@gmail.com>
Wed, 8 Nov 2023 12:50:55 +0000 (13:50 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 4 Jan 2024 20:40:50 +0000 (21:40 +0100)
This fixes a well known "LZMA ERROR 1" error on Sercomm NA502,
reported on the OpenWrt forum. [1]

[1]: https://forum.openwrt.org/t/176942

Signed-off-by: Szabolcs Hubai <szab.hu@gmail.com>
(cherry picked from commit d41b8a570f209c352571f209c2c8f2b52b8d27af)

target/linux/ramips/image/mt7621.mk

index d456176a0178ea2492258b847f54cae216dfaf43..e20a3e99aa765fd9c766a4b7e90f0fda1b0fc395 100644 (file)
@@ -1973,6 +1973,7 @@ TARGET_DEVICES += samknows_whitebox-v8
 
 define Device/sercomm_na502
   $(Device/nand)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 20480k
   DEVICE_VENDOR := SERCOMM
   DEVICE_MODEL := NA502