ar71xx: add model detection for UniFi AC-LR
authorAndreas Ziegler <dev@andreas-ziegler.de>
Tue, 22 Oct 2019 20:44:29 +0000 (22:44 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sun, 27 Oct 2019 17:13:33 +0000 (18:13 +0100)
This commit adds correct model detection for UniFi
AC-LR. Previously, said device was incorrectly detected
as UniFi-AC-LITE/MESH.

The Information about the device is stored at 0xC in the EEPROM
partition. It corresponds to the sysid in /etc/board.info of the
Ubiquiti stock firmware.

Signed-off-by: Andreas Ziegler <dev@andreas-ziegler.de>
[adjust naming style of target to existing ones]
Signed-off-by: David Bauer <mail@david-bauer.net>
(cherry picked from commit 2bc7c519dcc0e7ca09feed24a3b9a105bc49f423)
Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/image/generic-ubnt.mk

index 894835b14d79e8f47a6ddf013980d11278d07e78..3f76c32854440d650c00125f0c0420679491b7ab 100755 (executable)
@@ -111,6 +111,9 @@ ubnt_unifi_ac_board_detect() {
        "e517")
                model="Ubiquiti UniFi-AC-LITE"
                ;;
+       "e527")
+               model="Ubiquiti UniFi-AC-LR"
+               ;;
        "e537")
                model="Ubiquiti UniFi-AC-PRO"
                ;;
index 5caad50b0ad1de2d07a8363896bd4155de405853..c7d17f20aaa480bd1acd43cc10e4fa40735d5f77 100644 (file)
@@ -138,6 +138,12 @@ define Device/ubnt-unifiac-lite
 endef
 TARGET_DEVICES += ubnt-unifiac-lite
 
+define Device/ubnt-unifiac-lr
+  $(Device/ubnt-unifiac-lite)
+  DEVICE_TITLE := Ubiquiti UniFi AC-LR
+endef
+TARGET_DEVICES += ubnt-unifiac-lr
+
 define Device/ubnt-unifiac-mesh
   $(Device/ubnt-unifiac-lite)
   DEVICE_TITLE := Ubiquiti UniFi AC-Mesh