ath79: move ubnt-xm 64M RAM boards back to generic
authorFelix Baumann <felix.bau@gmx.de>
Mon, 3 Jul 2023 23:35:43 +0000 (01:35 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 11 Aug 2023 10:53:34 +0000 (12:53 +0200)
return ubnt_rocket-m and ubnt_powerbridge-m back to ath79-generic
They have enough RAM-ressources to not be considered as tiny.

This reverts the commit f4415f7635164ec07ddc22f56df93555804b5767 partially

Signed-off-by: Felix Baumann <felix.bau@gmx.de>
(cherry picked from commit 9e86a96af5ecea6e73fa463d6cfa4408e2b49d35)

target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/image/generic-ubnt.mk
target/linux/ath79/image/tiny-ubnt.mk
target/linux/ath79/tiny/base-files/etc/board.d/01_leds
target/linux/ath79/tiny/base-files/etc/board.d/02_network
target/linux/ath79/tiny/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom

index 2ee4ed2544d97d5b27bf8135c8fdce27d5adc26a..b5cc4abf65e832596efb5633440cfb3d8fdff27b 100644 (file)
@@ -485,7 +485,9 @@ ubnt,bullet-m-xw|\
 ubnt,nanostation-loco-m-xw|\
 ubnt,nanostation-m-xw|\
 ubnt,powerbeam-m2-xw|\
-ubnt,powerbeam-m5-xw)
+ubnt,powerbeam-m5-xw|\
+ubnt,powerbridge-m|\
+ubnt,rocket-m)
        ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "red:link1" "wlan0" "1" "100"
        ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "orange:link2" "wlan0" "26" "100"
index 4f535f8a648e6c3e51cf6f22f358754355b8a6ec..0d7396a04dca98bce0be8e49e7118df670ce1043 100644 (file)
@@ -110,7 +110,9 @@ ath79_setup_interfaces()
        ubnt,powerbeam-5ac-gen2|\
        ubnt,powerbeam-m2-xw|\
        ubnt,powerbeam-m5-xw|\
+       ubnt,powerbridge-m|\
        ubnt,rocket-5ac-lite|\
+       ubnt,rocket-m|\
        ubnt,unifiac-lite|\
        ubnt,unifiac-lr|\
        ubnt,unifiac-mesh|\
@@ -785,6 +787,8 @@ ath79_setup_macs()
                wan_mac=$(mtd_get_mac_text mac 0x18)
                label_mac=$wan_mac
                ;;
+       ubnt,powerbridge-m|\
+       ubnt,rocket-m|\
        ubnt,unifi)
                label_mac=$(cat /sys/class/ieee80211/phy0/macaddress)
                ;;
index c46573ece5448ea6758cd0177e5adfc813dff9e2..f4c2b26d68f8b2cd59bf06e15dc89e93ce8c3f45 100644 (file)
@@ -109,6 +109,10 @@ case "$FIRMWARE" in
        tplink,tl-wr842n-v1)
                caldata_extract "art" 0x1000 0x3e0
                ;;
+       ubnt,powerbridge-m|\
+       ubnt,rocket-m)
+               caldata_extract "art" 0x1000 0x1000
+               ;;
        wd,mynet-n600|\
        wd,mynet-n750)
                caldata_extract "art" 0x5000 0x440
index 0f70649d0315035493d95cf0e14b8da17a2dd13d..fa4daa3aaafd2887096a18bc254d56165d9346a8 100644 (file)
@@ -158,6 +158,15 @@ define Device/ubnt_powerbeam-m5-xw
 endef
 TARGET_DEVICES += ubnt_powerbeam-m5-xw
 
+define Device/ubnt_powerbridge-m
+  $(Device/ubnt-xm)
+  SOC := ar7241
+  DEVICE_MODEL := PowerBridge M
+  DEVICE_PACKAGES += rssileds
+  SUPPORTED_DEVICES += bullet-m
+endef
+TARGET_DEVICES += ubnt_powerbridge-m
+
 define Device/ubnt_rocket-5ac-lite
   $(Device/ubnt-xc)
   SOC := qca9558
@@ -167,6 +176,15 @@ define Device/ubnt_rocket-5ac-lite
 endef
 TARGET_DEVICES += ubnt_rocket-5ac-lite
 
+define Device/ubnt_rocket-m
+  $(Device/ubnt-xm)
+  SOC := ar7241
+  DEVICE_MODEL := Rocket M
+  DEVICE_PACKAGES += rssileds
+  SUPPORTED_DEVICES += rocket-m
+endef
+TARGET_DEVICES += ubnt_rocket-m
+
 define Device/ubnt_routerstation_common
   DEVICE_PACKAGES := -kmod-ath9k -wpad-basic-mbedtls -uboot-envtools kmod-usb-ohci \
        kmod-usb2 fconfig
index 07333714418f2a8ff6a65536c19473062816eb84..77940ed875ab74f0a64010098fbccab6261c15de 100644 (file)
@@ -70,21 +70,3 @@ define Device/ubnt_nanostation-loco-m
   DEFAULT := n
 endef
 TARGET_DEVICES += ubnt_nanostation-loco-m
-
-define Device/ubnt_powerbridge-m
-  $(Device/ubnt-xm)
-  SOC := ar7241
-  DEVICE_MODEL := PowerBridge M
-  DEVICE_PACKAGES += rssileds
-  SUPPORTED_DEVICES += bullet-m
-endef
-TARGET_DEVICES += ubnt_powerbridge-m
-
-define Device/ubnt_rocket-m
-  $(Device/ubnt-xm)
-  SOC := ar7241
-  DEVICE_MODEL := Rocket M
-  DEVICE_PACKAGES += rssileds
-  SUPPORTED_DEVICES += rocket-m
-endef
-TARGET_DEVICES += ubnt_rocket-m
index 92c4499580fbea4be04d33b1fb4acea5a51c7be4..07e48ec49f3800df1c0fdc7fbdfbe958ee93dacf 100644 (file)
@@ -116,9 +116,7 @@ ubnt,bullet-m-ar7241|\
 ubnt,nanobridge-m|\
 ubnt,nanostation-loco-m|\
 ubnt,nanostation-m|\
-ubnt,picostation-m|\
-ubnt,powerbridge-m|\
-ubnt,rocket-m)
+ubnt,picostation-m)
        ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "red:link1" "wlan0" "1" "100"
        ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "orange:link2" "wlan0" "26" "100"
index 4f6e2918a45c330116dcb854a3bc94eeed62a93c..836d119867fb98c05be25addd88c4307174c6a21 100644 (file)
@@ -54,9 +54,7 @@ ath79_setup_interfaces()
        ubnt,bullet-m-ar7241|\
        ubnt,nanobridge-m|\
        ubnt,picostation-m|\
-       ubnt,nanostation-loco-m|\
-       ubnt,powerbridge-m|\
-       ubnt,rocket-m)
+       ubnt,nanostation-loco-m)
                ucidef_set_interface_lan "eth0"
                ;;
        engenius,enh202-v1)
@@ -135,9 +133,7 @@ ath79_setup_macs()
        ubnt,nanobridge-m|\
        ubnt,nanostation-loco-m|\
        ubnt,nanostation-m|\
-       ubnt,picostation-m|\
-       ubnt,powerbridge-m|\
-       ubnt,rocket-m)
+       ubnt,picostation-m)
                label_mac=$(cat /sys/class/ieee80211/phy0/macaddress)
                ;;
        tplink,tl-wr941-v2|\
index 792c503ab7dd813e57bf9d8c9e7d184504a6dc3f..d424b9fe2ca80c96fdd4e1781733488021d82b61 100644 (file)
@@ -43,9 +43,7 @@ case "$FIRMWARE" in
        ubnt,nanobridge-m|\
        ubnt,nanostation-loco-m|\
        ubnt,nanostation-m|\
-       ubnt,picostation-m|\
-       ubnt,powerbridge-m|\
-       ubnt,rocket-m)
+       ubnt,picostation-m)
                caldata_extract "art" 0x1000 0x1000
                ;;
        pqi,air-pen)