ath79: add support for UniFi AC-LR
authorAndreas Ziegler <dev@andreas-ziegler.de>
Sun, 6 Oct 2019 17:48:34 +0000 (19:48 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sun, 27 Oct 2019 17:31:53 +0000 (18:31 +0100)
The Unifi AC-LR has identical hardware to the Unifi AC-Lite.
The antenna setup is different according to the vendor,
which explains the thicker enclosure.

Therefore, it is helpful to know the exact device variant,
instead of having "Ubiquiti UniFi-AC-LITE/LR".

Signed-off-by: Andreas Ziegler <dev@andreas-ziegler.de>
[fix legacy name in commit message; add old boardname to
SUPPORTED_DEVICES]
Signed-off-by: David Bauer <mail@david-bauer.net>
(cherry picked from commit 07c1ddf522dbe6085af664cf03a41f636a70b99c)
Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts
target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts [new file with mode: 0644]
target/linux/ath79/image/generic-ubnt.mk

index 65df0c60436bf7b47c93fbb7e5067e32c3731c90..82c1e09981407f49ff33bc9d71e0a22593a7d03b 100755 (executable)
@@ -40,6 +40,7 @@ ath79_setup_interfaces()
        ubnt,nanostation-ac-loco|\
        ubnt,rocket-m|\
        ubnt,unifiac-lite|\
+       ubnt,unifiac-lr|\
        ubnt,unifiac-mesh|\
        ubnt,unifi|\
        wd,mynet-wifi-rangeextender|\
index 06a48e2258c3b45bed045901933fe9846600a121..d1f529fde5097400d5e4a663da2fe7ee07eb0f82 100644 (file)
@@ -164,6 +164,7 @@ case "$FIRMWARE" in
                ath10kcal_patch_mac $(macaddr_add $(mtd_get_mac_binary info 8) +1)
                ;;
        ubnt,unifiac-lite|\
+       ubnt,unifiac-lr|\
        ubnt,unifiac-mesh|\
        ubnt,unifiac-mesh-pro|\
        ubnt,lap-120|\
index a3ae7089d5067b3d6bdd3a5cc52a41f55842c5fc..7b9fa0701b8f8f7c8588cabbecf1b85500ce2fe0 100644 (file)
@@ -5,5 +5,5 @@
 
 / {
        compatible = "ubnt,unifiac-lite", "qca,qca9563";
-       model = "Ubiquiti UniFi-AC-LITE/LR";
+       model = "Ubiquiti UniFi-AC-LITE";
 };
diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts b/target/linux/ath79/dts/qca9563_ubnt_unifiac-lr.dts
new file mode 100644 (file)
index 0000000..a1e542a
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9563_ubnt_unifiac-lite.dtsi"
+
+/ {
+       compatible = "ubnt,unifiac-lr", "qca,qca9563";
+       model = "Ubiquiti UniFi-AC-LR";
+};
index c51d743a354546bdad996203160120c9e063b5f2..fdc0d280337d891257ed9666936ff80460d3384a 100644 (file)
@@ -177,6 +177,13 @@ define Device/ubnt_unifiac-lite
 endef
 TARGET_DEVICES += ubnt_unifiac-lite
 
+define Device/ubnt_unifiac-lr
+  $(Device/ubnt_unifiac)
+  DEVICE_TITLE := Ubiquiti UniFi AC-LR
+  SUPPORTED_DEVICES += unifiac-lite ubnt,unifiac-lite
+endef
+TARGET_DEVICES += ubnt_unifiac-lr
+
 define Device/ubnt_unifiac-mesh
   $(Device/ubnt_unifiac)
   DEVICE_TITLE := Ubiquiti UniFi AC-Mesh