kernel: bump 4.14 to 4.14.165
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 10:05:48 +0000 (11:05 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 12:44:38 +0000 (13:44 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch

index 35188a0776462b52fd101b3e9b561d3579b48531..8b3834147cbbf89fef21e005c519b76be1c6566b 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .210
-LINUX_VERSION-4.14 = .164
+LINUX_VERSION-4.14 = .165
 
 LINUX_KERNEL_HASH-4.9.210 = a0915203836d02cc3cd70252904700412c4a409737a81b392465fb70d7625313
-LINUX_KERNEL_HASH-4.14.164 = a2031061f3f1472b7fa929f7d0274dd985c8d03ca847acfec1c47847fb7deb4b
+LINUX_KERNEL_HASH-4.14.165 = b0aeb52386404f4e3546f93cf63c857025fc3117ff1b56e3499aa1eae6e088c7
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 59e1cff9658202243f59a05895fa0c1639477d72..f70cfef7624737d83c392e5a0d1cce9ff4c6d2df 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1970,7 +1970,8 @@ static const struct usb_device_id option
+@@ -1975,7 +1975,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },