ipq-wifi: fix upstream board-2.bin ZTE M289F snafu
authorChristian Lamparter <chunkeey@gmail.com>
Tue, 4 Jul 2023 18:42:22 +0000 (20:42 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Tue, 4 Jul 2023 20:11:53 +0000 (22:11 +0200)
The upstream board-2.bin file in the linux-firmware.git
repository for the QCA4019 contains a packed board-2.bin
for this device for both 2.4G and 5G wifis. This isn't
something that the ath10k driver supports.

Until this feature either gets implemented - which is
very unlikely -, or the upstream boardfile is mended
(both, the original submitter and ath10k-firmware
custodian have been notified). OpenWrt will go back
and use its own bespoke boardfile. This unfortunately
means that 2.4G and on some revisions the 5G WiFi is
not available in the initramfs image for this device.

qca9984 isn't affected.

Fixes: #12886
Reported-by: Christian Heuff <christian@heuff.at>
Debugged-by: Georgios Kourachanis <geo.kourachanis@gmail.com>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
(cherry picked from commit 75505c5ec724b9b961dcb411bac1d4b9aede3e1d)

package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-zte_mf289f.qca4019 [new file with mode: 0644]
target/linux/ipq40xx/image/generic.mk

index d5ffd2084ed1b4fdc1d35675a7b8cbe551e1ebf0..4ccf05af8d2b0ee2f0141df6a1caca77955c62c7 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=ipq-wifi
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_FLAGS:=nonshared
 
 include $(INCLUDE_DIR)/package.mk
@@ -24,7 +24,8 @@ endef
 # You can find instructions and examples on the linux-wireless wiki:
 # <https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles>
 
-ALLWIFIBOARDS:=
+ALLWIFIBOARDS:= \
+       zte_mf289f
 
 ALLWIFIPACKAGES:=$(foreach BOARD,$(ALLWIFIBOARDS),ipq-wifi-$(BOARD))
 
@@ -85,4 +86,6 @@ endef
 # Place files in this directory as board-<devicename>.<qca4019|qca9888|qca9984>
 # Add $(eval $(call generate-ipq-wifi-package,<devicename>,<display name>))
 
-#$(foreach PACKAGE,$(ALLWIFIPACKAGES),$(eval $(call BuildPackage,$(PACKAGE))))
+$(eval $(call generate-ipq-wifi-package,zte_mf289f,ZTE MF289F))
+
+$(foreach PACKAGE,$(ALLWIFIPACKAGES),$(eval $(call BuildPackage,$(PACKAGE))))
diff --git a/package/firmware/ipq-wifi/board-zte_mf289f.qca4019 b/package/firmware/ipq-wifi/board-zte_mf289f.qca4019
new file mode 100644 (file)
index 0000000..3a4cb8b
Binary files /dev/null and b/package/firmware/ipq-wifi/board-zte_mf289f.qca4019 differ
index 9dfa877c328fc5cb285daf25401b0f07a0bd7061..b8e3edf8575db575811c82697164c89f584a4b1a 100644 (file)
@@ -1003,7 +1003,7 @@ TARGET_DEVICES += zte_mf286d
 define Device/zte_mf289f
        $(call Device/zte_mf28x_common)
        DEVICE_MODEL := MF289F
-       DEVICE_PACKAGES += ath10k-firmware-qca9984-ct
+       DEVICE_PACKAGES += ipq-wifi-zte_mf289f ath10k-firmware-qca9984-ct
 endef
 TARGET_DEVICES += zte_mf289f