ipq40xx: luma_wrtq-329acn: convert to DSA
authorTomasz Maciej Nowak <tmn505@gmail.com>
Mon, 3 Oct 2022 12:58:53 +0000 (14:58 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 5 Oct 2022 17:10:28 +0000 (19:10 +0200)
Convert luma_wrtq-329acn device to DSA and enable it.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Reviewed-by: Robert Marko <robimarko@gmail.com>
[ improve commit description ]
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wrtq-329acn.dts
target/linux/ipq40xx/image/generic.mk

index 3d05589369b50c026f7bb3cd9faf9bcf09c4ee79..d9a162b10d42c207b18f41eef01606bc292ef8ba 100644 (file)
@@ -30,6 +30,7 @@ ipq40xx_setup_interfaces()
        cilab,meshpoint-one|\
        edgecore,ecw5211|\
        glinet,gl-b2200|\
+       luma,wrtq-329acn|\
        mikrotik,cap-ac|\
        netgear,wac510)
                ucidef_set_interfaces_lan_wan "lan" "wan"
index 2407698fe1c89ea9ade575b115b355e131850fc2..4694c56819145928760123af2e6b6ccac57badc8 100644 (file)
                        status = "okay";
                };
 
-               mdio@90000 {
-                       status = "okay";
-               };
-
                tcsr@1949000 {
                        compatible = "qcom,tcsr";
                        reg = <0x1949000 0x100>;
        status = "okay";
 };
 
+&gmac {
+       status = "okay";
+};
+
+&ethphy0 {
+       status = "disabled";
+};
+
+&ethphy1 {
+       status = "disabled";
+};
+
+&ethphy3 {
+       status = "disabled";
+};
+
+&mdio {
+       status = "okay";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport3 {
+       status = "okay";
+
+       label = "lan";
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_art_6>;
+};
+
+&swport5 {
+       status = "okay";
+
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_art_0>;
+};
+
 &tlmm {
        serial0_pins: serial0_pinmux {
                mux {
        status = "okay";
 };
 
-&ethphy0 {
-       status = "disabled";
-};
-
-&ethphy1 {
-       status = "disabled";
-};
-
-&ethphy3 {
-       status = "disabled";
-};
-
 &wifi0 {
        status = "okay";
        nvmem-cell-names = "pre-calibration";
index 47e8c129b49c0749ada35e82075940ba469c8adb..69ec42c2665779b20baaf4353bb2f3fdcea07755 100644 (file)
@@ -727,8 +727,7 @@ define Device/luma_wrtq-329acn
        BLOCKSIZE := 128k
        PAGESIZE := 2048
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += luma_wrtq-329acn
+TARGET_DEVICES += luma_wrtq-329acn
 
 define Device/meraki_mr33
        $(call Device/FitImage)