ipq806x: Add kmod-sound-soc-ipq8064-storm
authorBrian Norris <computersforpeace@gmail.com>
Fri, 13 Jan 2023 05:32:20 +0000 (21:32 -0800)
committerChristian Marangi <ansuelsmth@gmail.com>
Sat, 21 Jan 2023 00:02:25 +0000 (01:02 +0100)
For IPQ8064 systems based off the "Google Storm" reference platform,
such as the TP-Link OnHub.

Signed-off-by: Brian Norris <computersforpeace@gmail.com>
target/linux/ipq806x/modules.mk

index 605504b0c33867bd0ad944212c3097d74aeafc20..a2b844d0f03cc3cbd64efa0ff480504bc23c140e 100644 (file)
@@ -14,3 +14,32 @@ define KernelPackage/phy-qcom-ipq806x-usb/description
 endef
 
 $(eval $(call KernelPackage,phy-qcom-ipq806x-usb))
+
+
+define KernelPackage/sound-soc-ipq8064-storm
+  TITLE:=Qualcomm IPQ8064 SoC support for Google Storm
+  DEPENDS:=@TARGET_ipq806x +kmod-sound-soc-core
+  KCONFIG:=\
+       CONFIG_IPQ_LCC_806X \
+       CONFIG_SND_SOC_QCOM \
+       CONFIG_SND_SOC_STORM \
+       CONFIG_SND_SOC_APQ8016_SBC=n \
+       CONFIG_SND_SOC_SC7180=n
+  FILES:=\
+       $(LINUX_DIR)/drivers/clk/qcom/lcc-ipq806x.ko \
+       $(LINUX_DIR)/sound/soc/codecs/snd-soc-max98357a.ko \
+       $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-cpu.ko \
+       $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-ipq806x.ko \
+       $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-platform.ko \
+       $(LINUX_DIR)/sound/soc/qcom/snd-soc-storm.ko
+  AUTOLOAD:=$(call AutoProbe,lcc-ipq806x \
+       snd-soc-max98357a snd-soc-lpass-ipq806x snd-soc-storm)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-ipq8064-storm/description
+ Provides sound support for the Google Storm platform, with a Qualcomm IPQ8064
+ SoC.
+endef
+
+$(eval $(call KernelPackage,sound-soc-ipq8064-storm))