pulseaudio update to v4.0
authorPeter Wagner <​tripolar@gmx.at>
Wed, 3 Jul 2013 09:55:34 +0000 (09:55 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Wed, 3 Jul 2013 09:55:34 +0000 (09:55 +0000)
remove udev dependency, to use the first soundcard without udev, comment
load-module module-detect
and add
load-module module-alsa-sink device=hw:0
to system.pa

Signed-off-by: Peter Wagner <tripolar@gmx.at>
SVN-Revision: 37144

sound/pulseaudio/Makefile
sound/pulseaudio/files/pulseaudio.init
sound/pulseaudio/patches/001-no_default_64mb_alloc.patch

index 59532df4702b1450c50a946097546edb4079524d..1928450084d23c004ffe09c7bfcdfe5c646a6884 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pulseaudio
-PKG_VERSION:=3.0
+PKG_VERSION:=4.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://freedesktop.org/software/pulseaudio/releases/
-PKG_MD5SUM:=47fd7eca8479c757822bee68a1feef25
+PKG_MD5SUM:=591f211db2790a7e4d222f2dc6858db3
 
 PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=intltool/host
@@ -30,7 +30,7 @@ define Package/pulseaudio/Default
   SECTION:=sound
   CATEGORY:=Sound
   DEPENDS:=+libspeexdsp +libsndfile +libltdl +libpthread \
-       +librt +alsa-lib +libjson +libopenssl +udev $(ICONV_DEPENDS) $(INTL_DEPENDS)
+       +librt +alsa-lib +libjson +libopenssl +libwrap $(ICONV_DEPENDS) $(INTL_DEPENDS)
   TITLE:=Network sound server
   URL:=http://www.pulseaudio.org
   PROVIDES:=pulseaudio
@@ -100,7 +100,6 @@ CONFIGURE_ARGS += \
        --enable-alsa \
        --disable-hal \
        --disable-gconf \
-       --disable-tcpwrap \
        --disable-nls \
        --disable-manpages \
        --enable-oss-output \
@@ -114,6 +113,7 @@ CONFIGURE_ARGS += \
        --disable-asyncns \
        --disable-lirc \
        --disable-bluez \
+       --disable-udev \
        --without-caps \
        --without-fftw
 
index 0ae8f1bd27af195facf04c0089c0da1f2eddb546..4ac63b3c3814391e284eff6db8c336b7ee635853 100644 (file)
@@ -2,6 +2,7 @@
 # Copyright (C) 2011 OpenWrt.org
 
 START=65
+STOP=65
 
 SERVICE_USE_PID=1
 SERVICE_PID_FILE=/var/run/pulse/pid
index 8762554899cd2f0925d7cb177297d36c6c9f15aa..00a2274167c6e6fff0c015f0a9b5102f4c3a23c6 100644 (file)
@@ -1,7 +1,5 @@
-Index: pulseaudio-0.99.2/src/pulsecore/memblock.c
-===================================================================
---- pulseaudio-0.99.2.orig/src/pulsecore/memblock.c    2011-08-15 10:41:56.000000000 +0200
-+++ pulseaudio-0.99.2/src/pulsecore/memblock.c 2011-08-18 13:54:53.000000000 +0200
+--- a/src/pulsecore/memblock.c
++++ b/src/pulsecore/memblock.c
 @@ -57,7 +57,7 @@
   * stored in SHM and our OS does not commit the memory before we use
   * it for the first time. */