ramips: fix lzma-loader for buffalo_WSR_600DHP
authorHaoan Li <lihaoan1001@163.com>
Wed, 5 Apr 2023 18:42:15 +0000 (02:42 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 Apr 2023 12:15:54 +0000 (14:15 +0200)
This fixes a well known "LZMA ERROR 1" error, reported previously on
numerous of similar devices.

Fixes: #11919
Signed-off-by: Haoan Li <lihaoan1001@163.com>
(cherry picked from commit c7b484f3647c58da2f86395228a9927290a6f6ed)

target/linux/ramips/image/mt7621.mk

index c3e2291a9d91bae234707b1d81277b645bdd6920..9c451c26bf180a0ea45a33f567def4770b07398e 100644 (file)
@@ -306,6 +306,7 @@ TARGET_DEVICES += buffalo_wsr-2533dhpl
 
 define Device/buffalo_wsr-600dhp
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Buffalo
   DEVICE_MODEL := WSR-600DHP