ramips: RT1800: fix invalid octal number error
authorMax Qian <public@maxqia.com>
Fri, 15 Sep 2023 04:54:30 +0000 (21:54 -0700)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 17 Sep 2023 20:46:01 +0000 (22:46 +0200)
This commit removes the padded zeros in the date formatting.
The padded zeros from the date command causes the numbers
to be interpreted as an octal number by printf. Months, days,
and years with the number 08 or 09 raise an error in printf as an
"invalid octal number" and get interpreted as a zero.

Signed-off-by: Max Qian <public@maxqia.com>
(cherry picked from commit 794349a28a7b9036b54e13487a96120609db924e)

target/linux/ramips/image/mt7621.mk

index 2675c7d08ba80605acd481697ac39104b09afddf..962d7ef44017d1ead2a44eb67cac041220709ca4 100644 (file)
@@ -88,7 +88,7 @@ define Build/belkin-header
 
        ( \
                type_fw_date=$$(printf "01%02x%02x%02x" \
-                       $$(date -d "@$(SOURCE_DATE_EPOCH)" "+%y %m %d")); \
+                       $$(date -d "@$(SOURCE_DATE_EPOCH)" "+%-y %-m %-d")); \
                hw_fw_ver=$$(printf "%02x%02x%02x%02x" \
                        $(hw_ver) $$(echo $(fw_ver) | cut -d. -f-3 | tr . ' ')); \
                fw_len_crc=$$(gzip -c $@ | tail -c 8 | od -An -tx8 | tr -d ' \n'); \