kernel: crypto: add kmod-crypto-chacha20poly1305
authorXu Wang <xwang1498@gmx.com>
Fri, 27 May 2022 22:21:43 +0000 (22:21 +0000)
committerStijn Tintel <stijn@linux-ipv6.be>
Fri, 3 Jun 2022 09:26:59 +0000 (12:26 +0300)
Needed by strongSwan IPsec VPN for strongswan-mod-chapoly. Not to be confused with
kmod-crypto-LIB-chacha20poly1305, which is an 8-byte nonce version used
by wireguard.

Signed-off-by: Xu Wang <xwang1498@gmx.com>
package/kernel/linux/modules/crypto.mk

index 6fd53f60806dfc16c72ee4080b2931bf6c6ada79..cf2cf6c3ac0afcea4bfd9515e7a69bcfbd5bbb90 100644 (file)
@@ -101,6 +101,18 @@ endef
 $(eval $(call KernelPackage,crypto-ccm))
 
 
+define KernelPackage/crypto-chacha20poly1305
+  TITLE:=ChaCha20-Poly1305 AEAD support, RFC7539 (used by strongSwan IPsec VPN)
+  DEPENDS:=+kmod-crypto-aead +kmod-crypto-manager
+  KCONFIG:=CONFIG_CRYPTO_CHACHA20POLY1305
+  FILES:=$(LINUX_DIR)/crypto/chacha20poly1305.ko
+  AUTOLOAD:=$(call AutoLoad,09,chacha20poly1305)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-chacha20poly1305))
+
+
 define KernelPackage/crypto-cmac
   TITLE:=Support for Cipher-based Message Authentication Code (CMAC)
   DEPENDS:=+kmod-crypto-hash