perl: Install /usr/bin/prove so test harness works
authorHamish Guthrie <hcg@openwrt.org>
Thu, 6 Dec 2012 14:13:37 +0000 (14:13 +0000)
committerHamish Guthrie <hcg@openwrt.org>
Thu, 6 Dec 2012 14:13:37 +0000 (14:13 +0000)
SVN-Revision: 34534

lang/perl/perlbase.mk

index d1cad978e74d00c78e0ad7964c16cab80a23b7e8..595cb1b8bf0f6f4d15d1da3850703ea1b4239ba1 100644 (file)
@@ -1466,7 +1466,9 @@ TITLE:=Test perl module
 endef
 
 define Package/perlbase-test/install
-$(call perlmod/Install,$(1),Test Test.pm,Test/Harness/TAP.pod Test/Tutorial.pod)
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/prove $(1)/usr/bin/
+       $(call perlmod/Install,$(1),Test Test.pm,Test/Harness/TAP.pod Test/Tutorial.pod)
 endef
 
 $(eval $(call BuildPackage,perlbase-test))