packages/scmpc: use new service functions
authorNicolas Thill <nico@openwrt.org>
Sat, 12 Nov 2011 01:30:27 +0000 (01:30 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 12 Nov 2011 01:30:27 +0000 (01:30 +0000)
SVN-Revision: 28968

sound/scmpc/Makefile
sound/scmpc/files/scmpc.init

index de36e41561b848cc37af9d4f212cf6768ac35f88..4013085e035205b6e2de217bba58b4a329bff063 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=scmpc
 PKG_VERSION:=0.2.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.berlios.de/scmpc
index 5b12d3512a2f30c7b1e81afc75e1b8f1a2a6bf8c..5327b6b11fe41de3e48278d3787febbb41ff63f7 100644 (file)
@@ -1,12 +1,15 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=94
 
+SERVICE_USE_PID=1
+
 start() {
-       mkdir -p /var/lib/scmpc
-       /usr/bin/scmpc
+       mkdir -m 0755 -p /var/lib/scmpc
+       service_start /usr/bin/scmpc
 }
 
 stop() {
-       killall scmpc
+       service_stop /usr/bin/scmpc
 }