kernel: add support for NFSv4
authorJohn Crispin <john@openwrt.org>
Wed, 28 Jan 2015 12:01:51 +0000 (12:01 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 28 Jan 2015 12:01:51 +0000 (12:01 +0000)
To: openwrt-devel@lists.openwrt.org

This work is based on Daniel Colascione's submission to the OpenWrt
devel mailing list on January 15th, 2014. I modified his patch so that
it applied to the current OpenWrt Barrier Breaker tree.

Signed-off-by: W. Michael Petullo <mike@flyn.org>
SVN-Revision: 44162

package/kernel/linux/modules/fs.mk
package/kernel/linux/modules/lib.mk
package/kernel/linux/modules/netsupport.mk

index c1174154a473138ef39cd3a7b9a01bf65504fb45..9e3470b6d7af0f8bc4d82d42abe683efd0ba41a3 100644 (file)
@@ -292,12 +292,24 @@ define KernelPackage/fs-nfs/description
  Kernel module for NFS support
 endef
 
+define KernelPackage/fs-nfs/config
+  if PACKAGE_kmod-fs-nfs
+       config KERNEL_NFS_V4
+               bool "Support NFSv4 in NFS client"
+               depends on PACKAGE_kmod-fs-sunrpc-auth-rpcgss
+               default n
+               help
+                 Select this option to support NFSv4 in the NFS server
+  endif
+endef
+
 $(eval $(call KernelPackage,fs-nfs))
 
 
 define KernelPackage/fs-nfs-common
   SUBMENU:=$(FS_MENU)
   TITLE:=Common NFS filesystem modules
+  DEPENDS:=+kmod-lib-oid-registry
   KCONFIG:= \
        CONFIG_LOCKD \
        CONFIG_SUNRPC
@@ -310,36 +322,40 @@ endef
 $(eval $(call KernelPackage,fs-nfs-common))
 
 
-define KernelPackage/fs-nfs-common-v4
+define KernelPackage/fs-sunrpc-auth-rpcgss
   SUBMENU:=$(FS_MENU)
-  TITLE:=Common NFS V4 filesystem modules
-  KCONFIG+=\
-       CONFIG_SUNRPC_GSS\
-       CONFIG_NFS_V4=y\
-       CONFIG_NFSD_V4=y
-  DEPENDS:= @BROKEN
-  FILES+=$(LINUX_DIR)/net/sunrpc/auth_gss/auth_rpcgss.ko
-  AUTOLOAD=$(call AutoLoad,30,auth_rpcgss)
-endef
-
-define KernelPackage/fs-nfs-common-v4/description
- Kernel modules for NFS V4 & NFSD V4 kernel support
+  TITLE:=GSS authentication for SUN RPC
+  DEPENDS:=+kmod-fs-nfs-common
+  KCONFIG:=CONFIG_SUNRPC_GSS
+  FILES:= \
+       $(LINUX_DIR)/net/sunrpc/auth_gss/auth_rpcgss.ko
+  AUTOLOAD:=$(call AutoLoad,30,auth_rpcgss)
 endef
 
-$(eval $(call KernelPackage,fs-nfs-common-v4))
-
+$(eval $(call KernelPackage,fs-sunrpc-auth-rpcgss))
 
 define KernelPackage/fs-nfsd
   SUBMENU:=$(FS_MENU)
   TITLE:=NFS kernel server support
-  DEPENDS:=+kmod-fs-nfs-common +kmod-fs-exportfs
-  KCONFIG:= \
+  DEPENDS:=+kmod-fs-nfs-common +kmod-fs-exportfs +kmod-fs-sunrpc-auth-rpcgss
+  KCONFIG= \
        CONFIG_NFSD \
        CONFIG_NFSD_FAULT_INJECTION=n
   FILES:=$(LINUX_DIR)/fs/nfsd/nfsd.ko
   AUTOLOAD:=$(call AutoLoad,40,nfsd)
 endef
 
+define KernelPackage/fs-nfsd/config
+  if PACKAGE_kmod-fs-nfsd
+       config KERNEL_NFSD_V4
+               bool "Support NFSv4 in NFS server"
+               depends on PACKAGE_kmod-fs-sunrpc-auth-rpcgss
+               default n
+               help
+                 Select this option to support NFSv4 in the NFS server
+  endif
+endef
+
 define KernelPackage/fs-nfsd/description
  Kernel module for NFS kernel server support
 endef
index cd919ba62e9f6844bc0d45b7308b856a17d0f6f9..a148da36ed8d232a23dc8e6fefd86b08e7e6b7d5 100644 (file)
@@ -202,3 +202,18 @@ define KernelPackage/lib-cordic/description
 endef
 
 $(eval $(call KernelPackage,lib-cordic))
+
+
+define KernelPackage/lib-oid-registry
+  SUBMENU:=$(LIB_MENU)
+  TITLE:=OID-Registry function support
+  KCONFIG:=CONFIG_OID_REGISTRY
+  FILES:=$(LINUX_DIR)/lib/oid_registry.ko
+  AUTOLOAD:=$(call AutoProbe,oid-registry)
+endef
+
+define KernelPackage/lib-oid-registry/description
+ Kernel module for OID-Registry function support
+endef
+
+$(eval $(call KernelPackage,lib-oid-registry))
index fc85e22f41faef17ab02a97401516d0b8352fdae..bffb09cf0c48f0829740877bd4aa73f164cc3295 100644 (file)
@@ -967,3 +967,17 @@ define KernelPackage/rxrpc/description
 endef
 
 $(eval $(call KernelPackage,rxrpc))
+
+define KernelPackage/dns-resolver
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=DNS-resolver modules
+  KCONFIG:=CONFIG_DNS_RESOLVER
+  FILES:= \
+       $(LINUX_DIR)/net/dns_resolver/dns_resolver.ko
+endef
+
+define KernelPackage/dns-resolver/description
+ Kernel modules for DNS-RESOLVER support
+endef
+
+$(eval $(call KernelPackage,dns-resolver))