xdp-tools: fix build with NLS enabled
authorDaniel Golle <daniel@makrotopia.org>
Wed, 6 Jul 2022 21:20:25 +0000 (22:20 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 6 Jul 2022 21:38:20 +0000 (22:38 +0100)
Make sure the 'configure' shell script finds the libintl when linking
the test programs for discovering libpcap and libbpf.

Reported-by: @trippleflux
Fixes: 6ad1bea2a603 ("xdp-tools: add package")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/network/utils/xdp-tools/Makefile
package/network/utils/xdp-tools/patches/010-configure-respect-LDFLAGS.patch [new file with mode: 0644]

index f0af555919d8db3f37107d26cd6b9ab5869032d4..7d831d0fece7d4ffebeac53259b55de279aa5459 100644 (file)
@@ -16,6 +16,7 @@ PKG_FLAGS:=nonshared
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/bpf.mk
+include $(INCLUDE_DIR)/nls.mk
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
@@ -76,6 +77,8 @@ define Package/xdpdump/description
 xdpdump - a simple tcpdump like tool for capturing packets at the XDP layer
 endef
 
+TARGET_LDFLAGS += $(INTL_LDFLAGS)
+
 CONFIGURE_VARS += \
        FORCE_SYSTEM_LIBBPF=1 \
        CC="$(TARGET_CC)" \
diff --git a/package/network/utils/xdp-tools/patches/010-configure-respect-LDFLAGS.patch b/package/network/utils/xdp-tools/patches/010-configure-respect-LDFLAGS.patch
new file mode 100644 (file)
index 0000000..b345454
--- /dev/null
@@ -0,0 +1,29 @@
+--- a/configure
++++ b/configure
+@@ -138,7 +138,7 @@ int main(int argc, char **argv) {
+     return 0;
+ }
+ EOF
+-    libpcap_err=$($CC -o $TMPDIR/libpcaptest $TMPDIR/libpcaptest.c  $LIBPCAP_CFLAGS $LIBPCAP_LDLIBS 2>&1)
++    libpcap_err=$($CC -o $TMPDIR/libpcaptest $TMPDIR/libpcaptest.c  $LIBPCAP_CFLAGS $LIBPCAP_LDLIBS $LDFLAGS 2>&1)
+     if [ "$?" -eq "0" ]; then
+         echo "HAVE_PCAP:=y" >>$CONFIG
+         [ -n "$LIBPCAP_CFLAGS" ] && echo 'CFLAGS += ' $LIBPCAP_CFLAGS >> $CONFIG
+@@ -186,7 +186,7 @@ int main(int argc, char **argv) {
+     return 0;
+ }
+ EOF
+-    libbpf_err=$($CC -o $TMPDIR/libbpftest $TMPDIR/libbpftest.c -Werror $LIBBPF_CFLAGS $LIBBPF_LDLIBS 2>&1)
++    libbpf_err=$($CC -o $TMPDIR/libbpftest $TMPDIR/libbpftest.c -Werror $LIBBPF_CFLAGS $LIBBPF_LDLIBS $LDFLAGS 2>&1)
+     if [ "$?" -eq "0" ]; then
+         echo "HAVE_FEATURES+=${config_var}" >>"$CONFIG"
+         echo "yes"
+@@ -253,7 +253,7 @@ int main(int argc, char **argv) {
+ }
+ EOF
+-        libbpf_err=$($CC -o $TMPDIR/libbpftest $TMPDIR/libbpftest.c -Werror $LIBBPF_CFLAGS $LIBBPF_LDLIBS 2>&1)
++        libbpf_err=$($CC -o $TMPDIR/libbpftest $TMPDIR/libbpftest.c -Werror $LIBBPF_CFLAGS $LIBBPF_LDLIBS $LDFLAGS 2>&1)
+         if [ "$?" -eq "0" ]; then
+             echo "SYSTEM_LIBBPF:=y" >>$CONFIG
+             echo "LIBBPF_VERSION=$LIBBPF_VERSION" >>$CONFIG