kernel: bump 4.14 to 4.14.215
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Jan 2021 14:42:22 +0000 (15:42 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Jan 2021 16:21:00 +0000 (17:21 +0100)
Refreshed all patches.

Compile-tested on: ipq40xx, lantiq/xrx200, x86/64, ipq806x
Runtime-tested on: ipq40xx, lantiq/xrx200, x86/64

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch

index 0d42e167c882c200f4fe84abb416444f1a79b359..6100a27d386810d4cc531adaf06d21e18f8dfe0f 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .214
+LINUX_VERSION-4.14 = .215
 
-LINUX_KERNEL_HASH-4.14.214 = f54296216ace09a1bf81efaa9dbbd4ebbe8631dbf22df9c6f286157db827391e
+LINUX_KERNEL_HASH-4.14.215 = 9a844e290c61b39dd23df507ba1d9c2b2b4365e5993a978b19f1eb5610b926da
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index ecef1a4b2b52f994dbc8d2c8b9f9a97de965ace7..a66f628e3c859d7742c768b6a9f542d7eb91cb09 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -2015,7 +2015,8 @@ static const struct usb_device_id option
+@@ -2017,7 +2017,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index 449165dca1b22b3a278280319b2005587201e24f..f140edea7051e2bb76b6e425697262136c1dbe42 100644 (file)
@@ -442,7 +442,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
  /* Global User Control 1 Register */
  #define DWC3_GUCTL1_PARKMODE_DISABLE_SS       BIT(17)
  #define DWC3_GUCTL1_TX_IPGAP_LINECHECK_DIS    BIT(28)
-@@ -478,6 +507,14 @@
+@@ -479,6 +508,14 @@
  #define DWC3_DEV_IMOD_INTERVAL_SHIFT  0
  #define DWC3_DEV_IMOD_INTERVAL_MASK   (0xffff << 0)
  
@@ -457,7 +457,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
  /* Structures */
  
  struct dwc3_trb;
-@@ -789,6 +826,7 @@ struct dwc3_scratchpad_array {
+@@ -790,6 +827,7 @@ struct dwc3_scratchpad_array {
   * @regs: base address for our registers
   * @regs_size: address space size
   * @fladj: frame length adjustment
@@ -465,7 +465,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
   * @irq_gadget: peripheral controller's IRQ number
   * @nr_scratch: number of scratch buffers
   * @u1u2: only used on revisions <1.83a for workaround
-@@ -844,6 +882,7 @@ struct dwc3_scratchpad_array {
+@@ -845,6 +883,7 @@ struct dwc3_scratchpad_array {
   * @setup_packet_pending: true when there's a Setup Packet in FIFO. Workaround
   * @three_stage_setup: set if we perform a three phase setup
   * @usb3_lpm_capable: set if hadrware supports Link Power Management
@@ -473,7 +473,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
   * @disable_scramble_quirk: set if we enable the disable scramble quirk
   * @u2exit_lfps_quirk: set if we enable u2exit lfps quirk
   * @u2ss_inp3_quirk: set if we enable P3 OK for U2/SS Inactive quirk
-@@ -925,6 +964,12 @@ struct dwc3 {
+@@ -926,6 +965,12 @@ struct dwc3 {
        enum usb_phy_interface  hsphy_mode;
  
        u32                     fladj;
@@ -486,7 +486,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
        u32                     irq_gadget;
        u32                     nr_scratch;
        u32                     u1u2;
-@@ -1009,6 +1054,7 @@ struct dwc3 {
+@@ -1010,6 +1055,7 @@ struct dwc3 {
        unsigned                setup_packet_pending:1;
        unsigned                three_stage_setup:1;
        unsigned                usb3_lpm_capable:1;
@@ -494,7 +494,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
  
        unsigned                disable_scramble_quirk:1;
        unsigned                u2exit_lfps_quirk:1;
-@@ -1029,6 +1075,11 @@ struct dwc3 {
+@@ -1030,6 +1076,11 @@ struct dwc3 {
  
        unsigned                tx_de_emphasis_quirk:1;
        unsigned                tx_de_emphasis:2;