kernel: bump 4.14 to 4.14.222
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 25 Feb 2021 08:18:53 +0000 (09:18 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 26 Feb 2021 09:11:21 +0000 (10:11 +0100)
Refreshed all patches.

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.14/950-0315-usb-gadget-ethernet-Re-enable-Jumbo-frames.patch
target/linux/generic/backport-4.14/320-v4.16-netfilter-nf_conntrack-add-IPS_OFFLOAD-status-bit.patch
target/linux/generic/backport-4.14/370-netfilter-nf_flow_table-fix-offloaded-connection-tim.patch
target/linux/generic/hack-4.14/207-disable-modorder.patch
target/linux/generic/hack-4.14/220-gc_sections.patch
target/linux/generic/hack-4.14/221-module_exports.patch
target/linux/generic/hack-4.14/930-crashlog.patch

index 89fe14522b93395dd16e3075771b22d38bd279f3..839a247213c59b4b28eedd527d0c9be6afc0c142 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .221
+LINUX_VERSION-4.14 = .222
 
-LINUX_KERNEL_HASH-4.14.221 = ce2254075ff4846f13380c1cf4bec1e351e5996a7dd109c200e222e49fd2c7e9
+LINUX_KERNEL_HASH-4.14.222 = 734082b03d9f8e43b123b0061f08045b70c34e3a4b09f8a8da6a287686dac744
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 8875a8ac371dbc147fa831004aab56c3b31b8ed9..fff3b6091f0ed13d13d3455ecbfa7aca3168d162 100644 (file)
@@ -18,9 +18,9 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
 
 --- a/drivers/usb/gadget/function/u_ether.c
 +++ b/drivers/usb/gadget/function/u_ether.c
-@@ -850,6 +850,10 @@ struct net_device *gether_setup_name_def
-       net->ethtool_ops = &ops;
-       SET_NETDEV_DEVTYPE(net, &gadget_type);
+@@ -855,6 +855,10 @@ struct net_device *gether_setup_name_def
+       net->min_mtu = ETH_HLEN;
+       net->max_mtu = GETHER_MAX_MTU_SIZE;
  
 +      /* MTU range: 14 - 15412 */
 +      net->min_mtu = ETH_HLEN;
index 6390cc4f2b1c50e7ae81e7456b00c6edb890f764..39ef23be2ac34703a78b8fac637470ee3b1b6305 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  };
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -974,6 +974,9 @@ static unsigned int early_drop_list(stru
+@@ -975,6 +975,9 @@ static unsigned int early_drop_list(stru
        hlist_nulls_for_each_entry_rcu(h, n, head, hnnode) {
                tmp = nf_ct_tuplehash_to_ctrack(h);
  
@@ -57,7 +57,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                if (nf_ct_is_expired(tmp)) {
                        nf_ct_gc_expired(tmp);
                        continue;
-@@ -1051,6 +1054,18 @@ static bool gc_worker_can_early_drop(con
+@@ -1052,6 +1055,18 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1087,6 +1102,11 @@ static void gc_worker(struct work_struct
+@@ -1088,6 +1103,11 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index d82854908fadec11117e5a3f14b7413e435c6d95..230c90f7c58881cb42709cdc4306dad9817cbbab 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -1054,18 +1054,6 @@ static bool gc_worker_can_early_drop(con
+@@ -1055,18 +1055,6 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1102,10 +1090,8 @@ static void gc_worker(struct work_struct
+@@ -1103,10 +1091,8 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index 2b06be7b1dc70b075e3b0755d4db72245d46f9ed..8ac07d23777d230fc6957d837fb1bd4394d56284 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1254,7 +1254,6 @@ endif
+@@ -1261,7 +1261,6 @@ endif
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
  
-@@ -1283,7 +1282,6 @@ _modinst_:
+@@ -1290,7 +1289,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi
index fbf49aba90ae38be708a0f07f7ae2287b35b57c7..7f5072c07120949acd957322e314ab9f18ef325d 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)
  KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
  KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -779,11 +784,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
+@@ -786,11 +791,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
  KBUILD_CFLAGS += $(call cc-option, -fno-inline-functions-called-once)
  endif
  
index 59a6528dd32838e5fd870496e906e05c110e5758..6cbe617d788f1182179d8ff8e65fa907da76dada 100644 (file)
@@ -90,7 +90,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        __used                                                          \
 --- a/scripts/Makefile.build
 +++ b/scripts/Makefile.build
-@@ -432,7 +432,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
+@@ -435,7 +435,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
  # Linker scripts preprocessor (.lds.S -> .lds)
  # ---------------------------------------------------------------------------
  quiet_cmd_cpp_lds_S = LDS     $@
index 3100d1fc0838510352b4ec80f9f4ee083eb2115c..397046ad626b2cfb4084555abe0fe944892a4e4a 100644 (file)
@@ -318,7 +318,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  #include <asm/sections.h>
  #include <linux/io.h>
-@@ -483,6 +484,8 @@ static void __init_memblock memblock_ins
+@@ -447,6 +448,8 @@ static void __init_memblock memblock_ins
        memblock_set_region_node(rgn, nid);
        type->cnt++;
        type->total_size += size;
@@ -327,7 +327,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  /**
-@@ -522,6 +525,8 @@ int __init_memblock memblock_add_range(s
+@@ -486,6 +489,8 @@ int __init_memblock memblock_add_range(s
                type->regions[0].flags = flags;
                memblock_set_region_node(&type->regions[0], nid);
                type->total_size = size;