hostapd: make country3 option configurable
authorTimo Sigurdsson <public_timo.s@silentcreek.de>
Tue, 15 Jun 2021 21:08:56 +0000 (23:08 +0200)
committerPaul Spooren <mail@aparcar.org>
Tue, 6 Jul 2021 00:03:27 +0000 (14:03 -1000)
The country3 option in hostapd.conf allows the third octet of the country
string to be set. It can be used e.g. to indicate indoor or outdoor use (see
hostapd.conf for further details). Make this option configurable but optional
in OpenWrt.

Signed-off-by: Timo Sigurdsson <public_timo.s@silentcreek.de>
[bump PKG_RELEASE, rebase]
Signed-off-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit 9f09c1936a4a13b67fcba632f7ca02331f685359)
Signed-off-by: Paul Spooren <mail@aparcar.org>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.sh

index 0779421b8d734e5ece0151501d13394512b2b7b1..628bbbec4dff764416c59bee59fad2c87c188d17 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=33
+PKG_RELEASE:=34
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 87fcaf03b30ad60aafeee3812773c01950a1aaac..ee338a93881e8a73452a07c53b45db463be937ad 100644 (file)
@@ -92,7 +92,7 @@ hostapd_common_add_device_config() {
        config_add_array basic_rate
        config_add_array supported_rates
 
-       config_add_string country
+       config_add_string country country3
        config_add_boolean country_ie doth
        config_add_boolean spectrum_mgmt_required
        config_add_int local_pwr_constraint
@@ -114,7 +114,7 @@ hostapd_prepare_device_config() {
 
        local base_cfg=
 
-       json_get_vars country country_ie beacon_int:100 dtim_period:2 doth require_mode legacy_rates \
+       json_get_vars country country3 country_ie beacon_int:100 dtim_period:2 doth require_mode legacy_rates \
                acs_chan_bias local_pwr_constraint spectrum_mgmt_required airtime_mode cell_density
 
        hostapd_set_log_options base_cfg
@@ -128,6 +128,7 @@ hostapd_prepare_device_config() {
 
        [ -n "$country" ] && {
                append base_cfg "country_code=$country" "$N"
+               [ -n "$country3" ] && append base_cfg "country3=$country3" "$N"
 
                [ "$country_ie" -gt 0 ] && {
                        append base_cfg "ieee80211d=1" "$N"