gstreamer: update grammar.y to build with bison 3
authorLuka Perkov <luka@openwrt.org>
Tue, 31 Dec 2013 00:44:18 +0000 (00:44 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 31 Dec 2013 00:44:18 +0000 (00:44 +0000)
In gstreamer's gst/parse/grammar.y, YYLEX_PARAM is no longer supported in bison
3. Replace YYLEX_PARAM with %lex-param.

Signed-off-by John Vogel <jvogel4@stny.rr.com>

SVN-Revision: 39182

multimedia/gstreamer/Makefile
multimedia/gstreamer/patches/001-no_docs.patch
multimedia/gstreamer/patches/002-no_tests.patch
multimedia/gstreamer/patches/003-no_translations.patch
multimedia/gstreamer/patches/004-add_gst_debug_log2_debug_symbol.patch
multimedia/gstreamer/patches/005-YYLEX_PARAM_to_lex-param.patch [new file with mode: 0644]

index a5e896fed21aa4f8c894bfa6f0716b82781f2f22..74983100729e472e643ae257087fb3bfeef7af60 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2012 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gstreamer
 PKG_VERSION:=0.10.36
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
@@ -190,4 +190,3 @@ $(eval $(call GstBuildLibrary,net,network classes))
 $(eval $(call BuildPackage,gstreamer))
 $(eval $(call BuildPackage,gstreamer-utils))
 $(eval $(call BuildPackage,libgstreamer))
-
index e94fd0045ba58b5b23af2fd28505a485b774162d..3b7f017b61caba476de4a328560736441589047b 100644 (file)
@@ -18,7 +18,7 @@
        common
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -445,7 +445,6 @@ aclocaldir = $(datadir)/aclocal
+@@ -469,7 +469,6 @@ aclocaldir = $(datadir)/aclocal
  aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
  SUBDIRS = pkgconfig \
        gst libs plugins tools tests \
@@ -26,7 +26,7 @@
        po \
        m4 \
        common
-@@ -454,7 +453,6 @@ SUBDIRS = pkgconfig \
+@@ -478,7 +477,6 @@ SUBDIRS = pkgconfig \
  # These are all the possible subdirs
  DIST_SUBDIRS = pkgconfig \
        gst libs plugins tools tests \
index 6058a386aa4a16f38b5b0c0508bf9e6315d50073..7561f73a4b60896eca5bfda260992fd7fe8e1f33 100644 (file)
@@ -19,7 +19,7 @@
        common
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -444,7 +444,7 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk
+@@ -468,7 +468,7 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk
  aclocaldir = $(datadir)/aclocal
  aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
  SUBDIRS = pkgconfig \
@@ -28,7 +28,7 @@
        po \
        m4 \
        common
-@@ -452,7 +452,7 @@ SUBDIRS = pkgconfig \
+@@ -476,7 +476,7 @@ SUBDIRS = pkgconfig \
  
  # These are all the possible subdirs
  DIST_SUBDIRS = pkgconfig \
index 8090563e5441c501c331939cc20a34bc1aa922db..1c64167ebc6c966dfe7950a7020727e6712d736d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -695,7 +695,6 @@ libs/gst/net/Makefile
+@@ -763,7 +763,6 @@ libs/gst/net/Makefile
  plugins/Makefile
  plugins/indexers/Makefile
  plugins/elements/Makefile
@@ -27,7 +27,7 @@
  
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -445,7 +445,6 @@ aclocaldir = $(datadir)/aclocal
+@@ -469,7 +469,6 @@ aclocaldir = $(datadir)/aclocal
  aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
  SUBDIRS = pkgconfig \
        gst libs plugins tools \
@@ -35,7 +35,7 @@
        m4 \
        common
  
-@@ -453,7 +452,6 @@ SUBDIRS = pkgconfig \
+@@ -477,7 +476,6 @@ SUBDIRS = pkgconfig \
  # These are all the possible subdirs
  DIST_SUBDIRS = pkgconfig \
        gst libs plugins tools \
index bc2e9e22916ce9a2f306cfe89f9d209bdf6a6ae9..061ad5b69a3430ac901c512cb6a439dc8b57c692 100644 (file)
@@ -1,6 +1,6 @@
---- gstreamer-0.10.36/gst/gstinfo.c 2011-12-30 02:14:34.000000000 +0100
-+++ gstreamer-0.10.36.modified/gst/gstinfo.c    2013-01-03 14:01:37.000000000 +0100
-@@ -462,6 +462,39 @@
+--- a/gst/gstinfo.c
++++ b/gst/gstinfo.c
+@@ -462,6 +462,39 @@ gst_debug_log (GstDebugCategory * catego
    va_end (var_args);
  }
  
@@ -40,4 +40,3 @@
  #ifdef _MSC_VER
  /* based on g_basename(), which we can't use because it was deprecated */
  static inline const gchar *
-
diff --git a/multimedia/gstreamer/patches/005-YYLEX_PARAM_to_lex-param.patch b/multimedia/gstreamer/patches/005-YYLEX_PARAM_to_lex-param.patch
new file mode 100644 (file)
index 0000000..f70f03e
--- /dev/null
@@ -0,0 +1,27 @@
+From 60516f4798894f958fc53b470e1283318d0f8706 Mon Sep 17 00:00:00 2001
+From: Kerrick Staley <kerrick@kerrickstaley.com>
+Date: Wed, 21 Aug 2013 06:59:29 +0000
+Subject: parse: make grammar.y work with Bison 3
+
+YYLEX_PARAM is no longer supported in Bison 3.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=706462
+---
+--- a/gst/parse/grammar.y
++++ b/gst/parse/grammar.y
+@@ -26,7 +26,6 @@
+  */
+ #define YYERROR_VERBOSE 1
+-#define YYLEX_PARAM scanner
+ #define YYENABLE_NLS 0
+@@ -648,6 +647,7 @@ static int yyerror (void *scanner, graph
+ %right '.'
+ %left '!' '='
++%lex-param { void *scanner }
+ %parse-param { void *scanner }
+ %parse-param { graph_t *graph }
+ %pure-parser