qoriq: pad rootfs with zeros
authorRussell Senior <russell@personaltelco.net>
Fri, 1 Dec 2023 21:48:56 +0000 (13:48 -0800)
committerStijn Tintel <stijn@linux-ipv6.be>
Sat, 2 Dec 2023 12:06:56 +0000 (14:06 +0200)
Presently, sysupgrade -n does *not* reset the overlayfs, retaining
unwanted filesystem contents. Adding PADDING=1 in front of
gen_image_generic.sh in image/Makefile ensures that the overlayfs is
recreated on firstboot.

Fixes: 080a769b4da8 ("qoriq: new target")
Signed-off-by: Russell Senior <russell@personaltelco.net>
[add Fixes tag, rewrite commit subject and message to respect line
length]
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
target/linux/qoriq/image/Makefile

index ec46e4d54321f5c7f44dd1d743596ee878201dfc..69fea238b5e21d0787edb9b53852e085460488d2 100644 (file)
@@ -13,7 +13,7 @@ define Build/sdcard-img
                 $(foreach dtb,$(DEVICE_DTS),$(CP) $(KDIR)/image-$(dtb).dtb $@.boot), \
                 $(CP) $(KDIR)/image-/*.dtb $@.boot)
 
-        $(SCRIPT_DIR)/gen_image_generic.sh \
+        PADDING=1 $(SCRIPT_DIR)/gen_image_generic.sh \
                 $@ \
                 $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
                 $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS) \