binutils: move /usr/bin/strings to /bin/strings, avoids clash with busybox applet
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 27 Oct 2011 23:24:19 +0000 (23:24 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 27 Oct 2011 23:24:19 +0000 (23:24 +0000)
SVN-Revision: 28640

devel/binutils/Makefile

index 79dcc0336e609ae75189fba722c6ce70887cbd79..50580e458da920a14b89e8f1820240734ae60606 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=binutils
 PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
 #"))
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE_URL:=@GNU/binutils
 PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
@@ -101,8 +101,9 @@ define Package/objdump/install
 endef
 
 define Package/binutils/install
-       $(INSTALL_DIR) $(1)/usr
+       $(INSTALL_DIR) $(1)/usr $(1)/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ $(1)/usr/
+       mv $(1)/usr/bin/strings $(1)/bin/strings
        rm -f $(1)/usr/bin/objdump
 endef