kernel: bump 5.4 to 5.4.21
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 21 Feb 2020 14:45:40 +0000 (15:45 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 25 Feb 2020 19:20:58 +0000 (20:20 +0100)
Refreshed all patches.

Fixes:
- CVE-2019-3016
- CVE-2013-1798

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
target/linux/ath79/patches-5.4/0036-GPIO-add-named-gpio-exports.patch
target/linux/ath79/patches-5.4/405-mtd-tp-link-partition-parser.patch
target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch
target/linux/cns3xxx/patches-5.4/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
target/linux/cns3xxx/patches-5.4/200-broadcom_phy_reinit.patch
target/linux/mpc85xx/patches-5.4/001-powerpc-85xx-add-gpio-keys-to-of-match-table.patch
target/linux/mpc85xx/patches-5.4/100-powerpc-85xx-tl-wdr4900-v1-support.patch
target/linux/mpc85xx/patches-5.4/102-powerpc-add-cmdline-override.patch

index c07d3d3fea67cf5a3376e14cb207869907d7ff5b..d4ea379159260064a5898a3c2f2765154baf7b5d 100644 (file)
@@ -22,8 +22,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include "gpiolib.h"
  #include "gpiolib-of.h"
-@@ -895,3 +897,68 @@ void of_gpiochip_remove(struct gpio_chip
-       gpiochip_remove_pin_ranges(chip);
+@@ -915,3 +917,68 @@ void of_gpiochip_remove(struct gpio_chip
+ {
        of_node_put(chip->of_node);
  }
 +
@@ -141,7 +141,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  {
 --- a/include/linux/gpio/consumer.h
 +++ b/include/linux/gpio/consumer.h
-@@ -661,6 +661,7 @@ static inline void devm_acpi_dev_remove_
+@@ -668,6 +668,7 @@ static inline void devm_acpi_dev_remove_
  
  #if IS_ENABLED(CONFIG_GPIOLIB) && IS_ENABLED(CONFIG_GPIO_SYSFS)
  
@@ -149,7 +149,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  int gpiod_export(struct gpio_desc *desc, bool direction_may_change);
  int gpiod_export_link(struct device *dev, const char *name,
                      struct gpio_desc *desc);
-@@ -668,6 +669,13 @@ void gpiod_unexport(struct gpio_desc *de
+@@ -675,6 +676,13 @@ void gpiod_unexport(struct gpio_desc *de
  
  #else  /* CONFIG_GPIOLIB && CONFIG_GPIO_SYSFS */
  
index 7ea07f376c9c2bf9fbd06ccb8a70d57905abe771..11d1869544a595a6258c54c5f32f426c8df68b4e 100644 (file)
@@ -21,5 +21,5 @@
  obj-y                         += parsers/
 +obj-$(CONFIG_MTD_TPLINK_PARTS)        += tplinkpart.o
  
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_BLKDEVS)     += mtd_blkdevs.o
+ obj-$(CONFIG_MTD_SPLIT)               += mtdsplit/
index f808aa798a13abfbb3260d4736682f5765655492..3ac89f1e5c84a99ed5e12767fe5874af3dcd8497 100644 (file)
        list_for_each_entry(p, head, list) {
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -457,48 +457,53 @@ static void tcp_options_write(__be32 *pt
+@@ -460,48 +460,53 @@ static void tcp_options_write(__be32 *pt
        u16 options = opts->options;    /* mungable copy */
  
        if (unlikely(OPTION_MD5 & options)) {
        }
  
        if (unlikely(opts->num_sack_blocks)) {
-@@ -506,16 +511,17 @@ static void tcp_options_write(__be32 *pt
+@@ -509,16 +514,17 @@ static void tcp_options_write(__be32 *pt
                        tp->duplicate_sack : tp->selective_acks;
                int this_sack;
  
                }
  
                tp->rx_opt.dsack = 0;
-@@ -528,13 +534,14 @@ static void tcp_options_write(__be32 *pt
+@@ -531,13 +537,14 @@ static void tcp_options_write(__be32 *pt
  
                if (foc->exp) {
                        len = TCPOLEN_EXP_FASTOPEN_BASE + foc->len;
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3953,14 +3953,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3958,14 +3958,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
        ptr = ip6hoff + sizeof(struct ipv6hdr);
 --- a/include/net/neighbour.h
 +++ b/include/net/neighbour.h
-@@ -274,8 +274,10 @@ static inline bool neigh_key_eq128(const
+@@ -273,8 +273,10 @@ static inline bool neigh_key_eq128(const
        const u32 *n32 = (const u32 *)n->primary_key;
        const u32 *p32 = pkey;
  
   * No flags defined yet.
 --- a/net/core/utils.c
 +++ b/net/core/utils.c
-@@ -443,8 +443,14 @@ void inet_proto_csum_replace16(__sum16 *
+@@ -460,8 +460,14 @@ void inet_proto_csum_replace16(__sum16 *
                               bool pseudohdr)
  {
        __be32 diff[] = {
index 7f82d50186933ad954f607c63e14e8abccd03311..5802fef2001df007edc7d34f6d3116614e1aa0b5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/pci/probe.c
 +++ b/drivers/pci/probe.c
-@@ -2615,7 +2615,8 @@ static void pcie_write_mrrs(struct pci_d
+@@ -2622,7 +2622,8 @@ static void pcie_write_mrrs(struct pci_d
         * In the "safe" case, do not configure the MRRS.  There appear to be
         * issues with setting MRRS to 0 on a number of devices.
         */
index 5977b5948602037418fbe90b480c365d11f79b78..56881c2c049c5865fbd3bd456dbd23e5ea43b8bd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/broadcom.c
 +++ b/drivers/net/phy/broadcom.c
-@@ -438,7 +438,9 @@ static int bcm5481_config_aneg(struct ph
+@@ -433,7 +433,9 @@ static int bcm5481_config_aneg(struct ph
        ret = genphy_config_aneg(phydev);
  
        /* Then we can set up the delay. */
index 58c4be60070a9e9ea11d2bfcd2733fbcd55719bf..5e5ab10daf1d02096404701d5b56ef894ed3ad98 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/common.c
 +++ b/arch/powerpc/platforms/85xx/common.c
-@@ -33,6 +33,7 @@ static const struct of_device_id mpc85xx
+@@ -30,6 +30,7 @@ static const struct of_device_id mpc85xx
        { .compatible = "fsl,mpc8548-guts", },
        /* Probably unnecessary? */
        { .compatible = "gpio-leds", },
index c9256900d803ef7910731b0ccf3f30b159e7087c..7f56edfff70f7d6d873caa3a279f387691fc3bb8 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
 
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+@@ -161,6 +161,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
  src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
@@ -27,7 +27,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
  
  src-wlib := $(sort $(src-wlib-y))
  src-plat := $(sort $(src-plat-y))
-@@ -343,7 +344,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
+@@ -342,7 +343,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_SBC8548)                       += cuImage.sbc8548
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
@@ -38,7 +38,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
  
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -302,6 +302,11 @@ adder875-redboot)
+@@ -323,6 +323,11 @@ adder875-redboot)
      platformo="$object/fixed-head.o $object/redboot-8xx.o"
      binary=y
      ;;
index a99555f949bb4c9f5565c704cbb04c932d677dd8..b76793421a519f3fe7f6d27fbb25f0c2139fce89 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
-@@ -809,6 +809,14 @@ config CMDLINE_FORCE
+@@ -883,6 +883,14 @@ config CMDLINE_FORCE
          This is useful if you cannot or don't want to change the
          command-line options your boot loader passes to the kernel.
  
@@ -17,9 +17,9 @@
        help
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
-@@ -1091,6 +1091,17 @@ int __init early_init_dt_scan_chosen(uns
+@@ -1060,6 +1060,17 @@ int __init early_init_dt_scan_chosen(uns
        if (p != NULL && l > 0)
-               strlcpy(data, p, min((int)l, COMMAND_LINE_SIZE));
+               strlcpy(data, p, min(l, COMMAND_LINE_SIZE));
  
 +    /* CONFIG_CMDLINE_OVERRIDE is used to fallback to a different
 +     * device tree option of chosen/bootargs-override. This is