AA: ppp: backport r34536
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 6 Dec 2012 18:22:07 +0000 (18:22 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 6 Dec 2012 18:22:07 +0000 (18:22 +0000)
SVN-Revision: 34538

package/ppp/Makefile
package/ppp/files/ppp.sh

index e9a1e9c82b6a6f91175a017f98a2f37cb7069c5a..d7eddbc818e2ebefc8cee81bbec472c66b094f3b 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.5
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index 7e9b8dd8562a564ff4e8ec568a1c7ddac6764ca0..43a7de96585e0214d59ecf5e9401cd6e17b06115 100755 (executable)
@@ -16,8 +16,6 @@ ppp_generic_init_config() {
        proto_config_add_string "pppd_options"
        proto_config_add_string "connect"
        proto_config_add_string "disconnect"
-       proto_config_add_boolean "defaultroute"
-       proto_config_add_boolean "peerdns"
        proto_config_add_boolean "ipv6"
        proto_config_add_boolean "authfail"
        proto_config_add_int "mtu"
@@ -26,14 +24,8 @@ ppp_generic_init_config() {
 ppp_generic_setup() {
        local config="$1"; shift
 
-       json_get_vars ipv6 peerdns defaultroute demand keepalive username password pppd_options
+       json_get_vars ipv6 demand keepalive username password pppd_options
        [ "$ipv6" = 1 ] || ipv6=""
-       [ "$peerdns" = 0 ] && peerdns="" || peerdns="1"
-       if [ "$defaultroute" = 1 ]; then
-               defaultroute="defaultroute replacedefaultroute";
-       else
-               defaultroute="nodefaultroute"
-       fi
        if [ "${demand:-0}" -gt 0 ]; then
                demand="precompiled-active-filter /etc/ppp/filter demand idle $demand"
        else
@@ -51,8 +43,9 @@ ppp_generic_setup() {
                nodetach ipparam "$config" \
                ifname "${proto:-ppp}-$config" \
                ${keepalive:+lcp-echo-interval $interval lcp-echo-failure ${keepalive%%[, ]*}} \
-               ${ipv6:++ipv6} $defaultroute \
-               ${peerdns:+usepeerdns} \
+               ${ipv6:++ipv6} \
+               nodefaultroute \
+               usepeerdns \
                $demand maxfail 1 \
                ${username:+user "$username" password "$password"} \
                ${connect:+connect "$connect"} \