make QMAKE_LIBS modifiable from within OpenWrt Makefiles invoking qmake
authorMirko Vogt <mirko@openwrt.org>
Sat, 12 Feb 2011 19:56:38 +0000 (19:56 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 12 Feb 2011 19:56:38 +0000 (19:56 +0000)
SVN-Revision: 25489

Xorg/lib/qt4/files/qmake.mk
Xorg/lib/qt4/files/qws-qmake.conf
Xorg/lib/qt4/files/x11-qmake.conf

index 8413f584aa6a26e0e505ae4ce0a7fff9c0bc5855..96ec2a7e892655efde344fd9ae18388c8bbd3d7e 100644 (file)
@@ -22,6 +22,7 @@ define Build/Configure/Qmake
        TARGET_LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
        TARGET_INCDIRS="$(TARGET_INCDIRS)" \
        TARGET_LIBDIRS="$(TARGET_LIBDIRS)" \
+       TARGET_LIBS="$(TARGET_LIBS)" \
        STAGING_DIR_HOST="$(STAGING_DIR)/../host" \
        STAGING_DIR="$(STAGING_DIR)" \
        qmake \
index cec834c2b480d44591577b73d95aa5ba11a70f48..5e317dcd707783a0b3f7be4fc28e036312a3a816 100644 (file)
@@ -21,6 +21,7 @@ QMAKE_CFLAGS                                  = $$(TARGET_CFLAGS)
 QMAKE_CXXFLAGS                                 = $$(TARGET_CFLAGS)
 QMAKE_LINK                                             = $$(TARGET_CXX)
 QMAKE_LINK_C                                   = $$(TARGET_CC)
+QMAKE_LIBS                                             = $$(TARGET_LIBS)
 QMAKE_LFLAGS                                   = $$(TARGET_LDFLAGS) # this will end up in redundant "-L"-strings, as they're already in $QMAKE_LIBDIR_QT, however TARGET_LDFLAGS may contain not only directories but special linker options
 
 #unset vars which would intefere with vars/flags passed over by OpenWrt
index 48c754199c5bc438b2b1a2488b0f82666c153a99..b5a49c5f8ba3a7ffd65130132122c2b095d507ce 100644 (file)
@@ -26,6 +26,7 @@ QMAKE_CFLAGS                                  = $$(TARGET_CFLAGS)
 QMAKE_CXXFLAGS                                 = $$(TARGET_CFLAGS)
 QMAKE_LINK                                     = $$(TARGET_CXX)
 QMAKE_LINK_C                                   = $$(TARGET_CC)
+QMAKE_LIBS                                             = $$(TARGET_LIBS)
 QMAKE_LFLAGS                                   = $$(TARGET_LDFLAGS) # this will end up in redundant "-L"-strings, as they're already in $QMAKE_LIBDIR_QT, however TARGET_LDFLAGS may contain not only directories but special linker options
 
 #unset vars which would intefere with vars/flags passed over by OpenWrt