tools/elfutils: override SUBDIRS variable of Makefile
[openwrt/staging/stintel.git] / tools / elfutils / Makefile
index adf8770783e257cb46899fc5decec9eb81afd182..f13bd8c944b84e11c9d1a1a7a826f92db4046924 100644 (file)
@@ -17,6 +17,18 @@ PKG_CPE_ID:=cpe:/a:elfutils_project:elfutils
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
+PKG_SUBDIRS := \
+       libgnu \
+       config \
+       lib \
+       libelf \
+       libcpu \
+       backends \
+       libebl \
+       libdwelf \
+       libdwfl \
+       libdw
+
 include $(INCLUDE_DIR)/host-build.mk
 
 ifeq ($(HOST_OS),Darwin)
@@ -47,6 +59,14 @@ define Host/Gnulib
        ln -sf ../lib/eu-config.h $(HOST_BUILD_DIR)/libgnu/;
 endef
 
+define Host/Compile
+       $(call Host/Compile/Default,SUBDIRS='$$$$(wildcard $(PKG_SUBDIRS))')
+endef
+
+define Host/Install
+       $(call Host/Compile/Default,install SUBDIRS='$$$$(wildcard $(PKG_SUBDIRS))')
+endef
+
 define Host/Uninstall
        -$(call Host/Compile/Default,uninstall)
 endef