at91: fix image building with CONFIG_TARGET_MULTI_PROFILE
[openwrt/staging/kaloz.git] / target / linux / at91 / image / Makefile
index 12607073e4a75659180e156133c30bec558dd272..ccaeebe7cacf5b91bff92c9c2f97b55ebb89b360 100644 (file)
@@ -9,6 +9,10 @@ include $(INCLUDE_DIR)/image.mk
 
 KERNEL_LOADADDR := 0x20008000
 
+define Build/at91-install-zImage
+    $(CP) $(KDIR)/zImage $@
+endef
+
 ifeq ($(SUBTARGET),legacy)
 include ./legacy.mk
 endif
@@ -40,7 +44,7 @@ endef
 
 define Device/evaluation-zImage
   IMAGES += zImage
-  IMAGE/zImage := install-zImage
+  IMAGE/zImage := at91-install-zImage
 endef
 
 define Device/evaluation-dtb