prereq-build: remove python 2 cleanup recipe
[openwrt/staging/ldir.git] / include / prereq.mk
index 89660d323d9b82858ffda8498255522ed84b7aaa..5646b24efaa61a1f8b2c066901f192ea65508730 100644 (file)
@@ -77,18 +77,6 @@ define RequireCHeader
   $$(eval $$(call Require,$(1),$(2)))
 endef
 
-define CleanupPython2
-  define Require/python2-cleanup
-       if [ -f "$(STAGING_DIR_HOST)/bin/python" ] && \
-               $(STAGING_DIR_HOST)/bin/python -V 2>&1 | \
-               grep -q 'Python 2'; then \
-                       rm $(STAGING_DIR_HOST)/bin/python; \
-       fi
-  endef
-
-  $$(eval $$(call Require,python2-cleanup))
-endef
-
 define QuoteHostCommand
 '$(subst ','"'"',$(strip $(1)))'
 endef