[package] multiwan: fix health monitoring
authorFlorian Fainelli <florian@openwrt.org>
Wed, 19 Sep 2012 15:09:29 +0000 (15:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 19 Sep 2012 15:09:29 +0000 (15:09 +0000)
he extra space makes the ${health_monitor%.* } as "parallel.started", so it
won't match "parallel". This causes monitor_wan never starts.

Signed-off-by: York Sun <york.sun@me.com>
SVN-Revision: 33471

net/multiwan/Makefile
net/multiwan/files/usr/bin/multiwan

index 95faa123245e36ac8a17763be487678371eb953e..f5161cce610b1eab0b612e3f98b1ea0f8487efd1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=multiwan
 PKG_VERSION:=1.0.22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
index ebec4a9eb1780a407aa695c8f3e1534a1313c0aa..34cfa54f3f8ff678f8773961ad11eb8820a1d799 100755 (executable)
@@ -967,7 +967,7 @@ do_tasks() {
                        pass) recover_wan $1;;
                        acquire)
                            acquire_wan_data $1
-                           [ "${health_monitor%.* }" = 'parallel' ] && {
+                           [ "${health_monitor%.*}" = 'parallel' ] && {
                                monitor_wan $1 &
                                echo "## Started background monitor_wan ##"
                            }