realtek: add 6.1 as testing kernel realtek/testing-6.1
authorSander Vanheule <sander@svanheule.net>
Thu, 1 Feb 2024 20:06:28 +0000 (21:06 +0100)
committerSander Vanheule <sander@svanheule.net>
Sun, 4 Feb 2024 12:37:01 +0000 (13:37 +0100)
Kernel 6.1 successfully compiles and boots on devices from all
subtargets (Zyxel GS1900-8, Zyxel GS1900-48, Zyxel XGS1250-12).

Although not extensively tested yet, rtl838x and rtl839x appear to
function correctly.

The network bridge device on rtl930x is not fully functional yet.
Traffic can be received by the kernel, as the ARP table receives updates
on external pings. However, traffic is then lost somehow, and it appears
to be only sporadically possible to obtain a properly functioning link.

Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/realtek/Makefile

index cd86bdc11e6181d0b7aa7557d9cccb926a248505..b087b4d48cc0cf89ede1b26d1bcb0315d9614784 100644 (file)
@@ -10,6 +10,7 @@ FEATURES:=ramdisk squashfs
 SUBTARGETS:=rtl838x rtl839x rtl930x rtl931x
 
 KERNEL_PATCHVER:=5.15
+KERNEL_TESTING_PATCHVER:=6.1
 
 define Target/Description
        Build firmware images for Realtek RTL83xx based boards.